10 Replies Latest reply on Nov 9, 2010 1:30 PM by Bill Robinson

    JumpStart x86 Provisioning error

    Andres Alvarez

      Hi all,

       

      Well, my Solaris provisioning process continue and now is creating all scripts in JumpStart server, but i have an issue when modify network settings in Solaris Provisioning Job and re-run this.

       

      Next the error log  when provisioning job is executed:

       

      executing add install client script
      Error: unknown client "SYNBLPILSOL04"
      add install client failed
      Restoring device to imported state due to failed provisioning workitem

       

      Solaris documentation retaled this error to:

       

      In this case, hostname is not in /etc/hosts or DNS.

       

      I go to jumpstart /etc/hosts and /etc/ethers and server is setup in both files:

       

      192.168.97.130  synblpilsol04


      00:50:56:B3:49:4E SYNBLPILSOL04

       

      The job work fine with DHCP settings, only have an problem when call JumpStart menu, installation goes to interactive mode (next discussion) But if i select option 2 (custom jumpStart) this install fine Solaris.

       

      Thanks in advanced for any comments.

       

      Andres.

        • 1. Re: JumpStart x86 Provisioning error
          Bill Robinson

          Make sure the entires are in the same case?

          • 2. Re: JumpStart x86 Provisioning error
            Andres Alvarez

            I'm Sorry Bill but i don't understand your comment. Can you specified  this?

            Tks.

             

            Andres.

            • 3. Re: JumpStart x86 Provisioning error
              Bill Robinson

              You said you have the below in your files:

              192.168.97.130  synblpilsol04

              00:50:56:B3:49:4E SYNBLPILSOL04

               

              And you are getting the error Error: unknown client "SYNBLPILSOL04"

               

              SYNBLPILSOL04 is not in the same case as synblpilsol04, so it may be failing.  make sure all your references to the server ‘synblpilsol04’ are in either lower or upper case letters.

              • 4. Re: JumpStart x86 Provisioning error
                Andres Alvarez

                Tks Bill, this is correct. Newly you win .

                 

                I will continue on process.

                 

                Tks again.

                • 5. Re: JumpStart x86 Provisioning error
                  Andres Alvarez

                  Well, my proccess to provision Solaris is more close now tks to Bill, but now i have another problem.

                   

                  Provisioning log file show this:

                   

                  Info    Oct 25, 2010 3:58:21 PM    updating /etc/bootparams

                   

                  Info    Oct 25, 2010 3:58:21 PM    copying boot file to /tftpboot/pxegrub.I86PC.Solaris_10-1

                   

                  Error    Oct 25, 2010 3:58:21 PM    ln

                  Error    Oct 25, 2010 3:58:21 PM    : cannot create

                  Error    Oct 25, 2010 3:58:21 PM    /tftpboot//pxegrub.I86PC.Solaris_10-1

                  Error    Oct 25, 2010 3:58:21 PM    :

                  Error    Oct 25, 2010 3:58:21 PM    File exists

                   

                  I review in /tftpboot and delete all files and re-run the job but newly error is showed in appserver log.

                   

                  Another particularity is the double slash in error line /tftpboot//pxegrub.I86PC.Solaris_10-1

                   

                  Really, file pxegrub.I86PC.Solaris_10-1 is created and Provisioning proccess dotn abort, but my Solaris bare metal don't start JumpStart menu. Only view this error:

                   

                  solaris_error.png

                   

                  Tks for any comment.

                   

                  Andres.

                  • 6. Re: JumpStart x86 Provisioning error
                    Bill Robinson

                    the "can't create" error is probably ok because the file is there.

                     

                    the access violation is a problem... can you pull any files using a tftp client from this tftp server?

                    • 7. Re: JumpStart x86 Provisioning error
                      Andres Alvarez

                      Respect to this issue, problem was with boot files configuration in DHCP table.

                       

                      I was able to create an record in DHCP table for PXE boot clients trough pxegrub.I86PC.Solaris_10-1 file.

                       


                      Complete record in DHCP table is:

                       


                      PXEClient:Arch:00000:UNDI:002001        Macro           :BootFile="pxegrub.I86PC.Solaris_10-1":BootSrvA=192.168.97.127:

                       


                      You can view these records with command dhtadm -P in console.

                       


                      With this change, my PXE baremetal clients boot from JumpStart PXE, and goes to /tftpboot dir to donwload files created by BladeLogic. This guaranted JumpStart start install proccess and goes fine to JumpStart interactive menu.

                       


                      In this moment, my install proccess don't continue with unattended proccess and is request a install option in interactive menu:

                       


                      Select the type of installation you want to perform:

                               1 Solaris Interactive (default)
                               2 Custom JumpStart
                               3 Solaris Interactive Text (Desktop session)
                               4 Solaris Interactive Text (Console session)
                               5. Apply driver updates
                               6. Single User Shell
                      Enter the number of your choice.
                      Please make a selection (1-6).

                       


                      About this error, i found after so time , this is probably an Bug error in Solaris add_install_client command executed by BladeLogic to create grub menu (menu.lst) to installation parameters.

                       


                      In summary, in add_install_client command is mandatory add - install dhcp option to create in menu.lst an correct installation record.

                       


                      The record created by BladeLogic and Jumpstart is:

                       


                      title Solaris_10 Jumpstart
                              kernel /I86PC.Solaris_10-1/multiboot kernel/unix -B install_config=192.....

                       


                      With previous record, my install proccess goes to interactive menu. If i add option - install dhcp to menu.lst, install process is completly unattended:

                       


                      title Solaris_10 Jumpstart
                              kernel /I86PC.Solaris_10-1/multiboot kernel/unix - install dhcp -B install_config=192....

                       


                      Complete information about these bug here: http://www.sun.com/bigadmin/features/articles/jumpstart_x86_x64.jsp

                       


                      Well, problem now is how to make for add this option in menu.lst automatically and reach my BladeLogic install process continue unattended always?

                       


                      any comment is appreciated.

                       


                      Tks.

                      • 8. Re: JumpStart x86 Provisioning error
                        Bill Robinson

                        You need to edit the 'add_install_client' under the 'Tools' directory on your jumpstart server (it's buried in the OS media)

                         

                        each release seems to have slightly different issues.  for example, in the 10/09 release there is a section in the add_install_client:

                        printf "\tkernel\$ /${BootLofs}/multiboot " >> $Menufile
                                        printf "kernel/\$ISADIR/unix -B ${BARGLIST}" >> $Menufile
                                        if [ "${CONFIG_SERVER}" ]; then
                                                HOST_ADDR=""
                                                get_hostaddr ${CONFIG_SERVER}
                                                printf "install_config=" >> $Menufile
                                                printf "${HOST_ADDR:-${CONFIG_SERVER}}" >> $Menufile
                                                printf ":${CONFIG_PATH}," >> $Menufile
                                        fi

                         

                        There seem to be a number of issues here. the $ISADIR variable does not exist, and extra $  are appended to the 'kernel' option. Additionally, this will never generate a valid boot file, because we need to add the 'install' and 'nowin' to run the install and not show the X-windows environment. A good file looks like:

                         

                        printf "\tkernel /${BootLofs}/multiboot " >> $Menufile
                                        printf "kernel/unix - install nowin -B ${BARGLIST}" >> $Menufile
                                        if [ "${CONFIG_SERVER}" ]; then
                                                HOST_ADDR=""
                                                get_hostaddr ${CONFIG_SERVER}
                                                printf "install_config=" >> $Menufile
                                                printf "${HOST_ADDR:-${CONFIG_SERVER}}" >> $Menufile
                                                printf ":${CONFIG_PATH}," >> $Menufile
                                        fi

                         

                        Note the removal of $ at the end of the 'kernel' and, removal of $ISADIR and the addition of install and nowin.

                        • 9. Re: JumpStart x86 Provisioning error
                          Andres Alvarez

                          Yes  Bill !!!! You have the power

                           

                          Well, my JumpStart process now is unattended thanks to modify my add_install_client  command in Solaris_10 install files. (Solaris_10/Tools/)

                           

                          In my case, did not exist variables similar to those discussed by Bill. In short my lines were as follows:

                           

                          #
                                          # To automate jumpstart, we can set install in bootargs
                                          # Need more investigation before making it happen.
                                          #
                                          if [ "${CONFIG_SERVER}" ]; then
                                                  printf "\tkernel /${BootLofs}/multiboot " >> $Menufile
                                                 printf "kernel/unix - install nowin -B ${BARGLIST}" >> $Menufile
                                                  HOST_ADDR=""
                                                  get_hostaddr ${CONFIG_SERVER}
                                                  printf "install_config=" >> $Menufile
                                                  printf "${HOST_ADDR:-${CONFIG_SERVER}}" >> $Menufile
                                                  printf ":${CONFIG_PATH}," >> $Menufile
                                          else
                                                  printf "\tkernel /${BootLofs}/multiboot " >> $Menufile
                                                  printf "kernel/unix - install nowin -B ${BARGLIST}" >> $Menufile

                           

                          Is important review the comment created by Sun previous to these lines:

                          # To automate jumpstart, we can set install in bootargs

                          # Need more investigation before making it happen.

                           

                          In the same way, i think is important document this issue in BladeLogic official documentation as a WorkAround.

                           

                          Newly, thank Bill for all information about this.

                           

                          Andres Alvarez

                          Software Consultant Automation

                          Extension Latin America (Colombia)

                          • 10. Re: JumpStart x86 Provisioning error
                            Bill Robinson

                            The problem we've had w/ this, as you can see from what I posted, is that each version of Solaris introduces some differences in the add_install_client, none of which seem to work.  To be clear, you would have to make these changes to get a non-BladeLogic drive x86 Jumpstart to work, so this is really Sun's (Oracle's) problem.  I've seen 4 releases of solaris affected w/ a similar issue.