3 Replies Latest reply on Mar 6, 2018 2:59 PM by Virgelio Carpio

    SDE 10 Browser Idle Timeout

      Share:|

      Does anyone know how to change the global value of SDE 10's idle timeout period to 70 minutes?  Users are experiencing a 20 minute timeout with a 9 minute timer dialog appearing if their sessions sit for 10 minutes.

       

      I have tried all the following...

       

      - Changed idle timeout period in IIS under the Home Directory --> Configuration --> Options --> Session Timeout

      - Changed idle timeout period in IIS under ASP.NET --> Edit Global Configuration --> State Management

      - Changed idle timeout period in MS SQL 2005 DB under Tables --> SMSYSFLAGS --> featUTDefaultIdleTimeOut

      **The 4200 second timeout resets back to 1200 in the SQL DB once a user logs in and lets their session sit for 10 minutes.**

       

      IIS has been reset after changes were performed.

       

      I would like to not add a session timeout period to each individual group if possible.

       

       

       

      Thanks!

      Mickey

        • 1. Re: SDE 10 Browser Idle Timeout

          Hi there,

           

           

           

          You can set the maximum session timeout in IIS but going to IIS Manager, opening the website “Properties”, and in the .NET tab edit the configuration setting the ASP session timeout to any number of minutes.

           

           

           

          To set a different timeout for each SDE group, you will need to create a copy of the default Groups form, and in the copied form place the group timeout field (normally hidden), where you can specify group timeouts up to the maximum value set in IIS.

           

           

           

          Hope that helps,

           

          Hugo

          1 of 1 people found this helpful
          • 2. Re: SDE 10 Browser Idle Timeout

            Hugo,

             

            Thanks for your helpful input.

             

            The problem ended up to be some weird situation where just the SDE site was set to 20 minutes on the ASP.NET session timer even though the ASP.NET Global Session Timer Configuration was set to 70 minutes.  Setting each individual site to 70 minutes and making the 4200 second change to "Tables --> SMSYSFLAGS --> featUTDefaultIdleTimeOut" in the SQL DB seemed to address the issue.

             

             

             

            Thanks!

            Mickey

            • 3. Re: SDE 10 Browser Idle Timeout
              Virgelio Carpio

              Hi, Mickey. I'm having the same problem. When I change SMSYSFLAGS --> featUTDefaultIdleTimeOut (via SQL update) to, say, 7200, after first log in (after iisreset), it reverts back to 1200. In IIS, I changed Default Web Site's ASP->Session Properties->Time-out to 02:00:00 from 00:20:00 but the same reverting-back-to-1200 happens.

               

              I also exposed IDLETIMEOUT in our Group form and set all Groups to 7200 but still reverting-back-to-1200 happens.

               

              Would appreciate how you finally did it.

               

              Thanks a lot.