4 Replies Latest reply on Sep 17, 2010 1:39 PM by Mike Reider

    Can't authenticate after BL upgrade

    Mike Reider

      Hi everyone, I recently upgraded my app server from 7.4.2 to 8.00 via the recommended upgrade path.


      after I ran the Data Migration Manager, I upgraded the RSCD agent on same app box, but when I try to log in as RBACAdmin on the new 8.0.0 console, I get this error,


      cannot connet to "service:authsvc.bladelogic:blauth://blapp01:9640" - Connection refused: connect


      I checked the AuthServer settings for proper port config (9640) and checked the same on the Authentication Profile, its also 9640



      bladmin>show authServer all


      I dont know if its related but I also cannot telnet to port 4750, even though I see it as LISTENING if I run a nestat command.


      C:\Documents and Settings\Administrator>netstat -a


      Active Connections


        Proto  Local Address          Foreign Address        State
        TCP    blapp01:epmap          blapp01:0              LISTENING
        TCP    blapp01:microsoft-ds   blapp01:0              LISTENING
        TCP    blapp01:1025           blapp01:0              LISTENING
        TCP    blapp01:ms-sql-s       blapp01:0              LISTENING
        TCP    blapp01:4750           blapp01:0              LISTENING
        TCP    blapp01:9700           blapp01:0              LISTENING
        TCP    blapp01:9701           blapp01:0              LISTENING
        TCP    blapp01:9702           blapp01:0              LISTENING
        TCP    blapp01:ms-sql-m       blapp01:0              LISTENING
        TCP    blapp01:netbios-ssn    blapp01:0              LISTENING
        TCP    blapp01:netbios-ssn    blapp01:0              LISTENING
        TCP    blapp01:1204           blapp01:9702           ESTABLISHED
        TCP    blapp01:9702           blapp01:1204           ESTABLISHED
        UDP    blapp01:microsoft-ds   *:*
        UDP    blapp01:isakmp         *:*
        UDP    blapp01:1090           *:*
        UDP    blapp01:ipsec-msft     *:*
        UDP    blapp01:ntp            *:*
        UDP    blapp01:ntp            *:*
        UDP    blapp01:netbios-ns     *:*
        UDP    blapp01:netbios-dgm    *:*
        UDP    blapp01:ntp            *:*
        UDP    blapp01:netbios-ns     *:*
        UDP    blapp01:netbios-dgm    *:*


      9640 is not showing up as an open port (?)


      I dotn have a firewall running, so Im not sure whats blocking port 9640. PS, this is on Win2003, SQL2005, I refreshed the RSCD, SQL, App Server services after each step.

        • 1. Re: Can't authenticate after BL upgrade
          Jude Seth

          The default port for the Appserver/console communications is 9840.  What does the appserver log say?

          1 of 1 people found this helpful
          • 2. Re: Can't authenticate after BL upgrade
            Mike Reider

            hi Jude, I dont see anything new in log but there are these errors from earlier today, Im looking into this error now. thanks!



            [17 Sep 2010 11:57:00,937] [main] [ERROR] [::] [] Error installing to Start: name=bladelogic.service.DatabaseService state=Create
            com.bladelogic.app.service.ServiceInitializationException: Rule migration process did not run. Please run rule migration.

                at com.bladelogic.app.service.db.DatabaseServiceImpl.checkRuleMigration(DatabaseServiceImpl.java:318)
                at com.bladelogic.app.service.db.DatabaseServiceImpl.start(DatabaseServiceImpl.java:303)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                at java.lang.reflect.Method.invoke(Unknown Source)
                at org.jboss.joinpoint.plugins.reflect.ReflectMethodJoinPoint.dispatch(ReflectMethodJoinPoint.java:72)
                at org.jboss.kernel.plugins.dependency.KernelControllerContextActions.dispatchJoinPoint(KernelControllerContextActions.java:92)
                at org.jboss.kernel.plugins.dependency.KernelControllerContextActions$LifecycleAction.installAction(KernelControllerContextActions.java:452)
                at org.jboss.kernel.plugins.dependency.KernelControllerContextActions$KernelControllerContextAction.install(KernelControllerContextActions.java:147)
                at org.jboss.dependency.plugins.AbstractControllerContextActions.install(AbstractControllerContextActions.java:51)
                at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:226)
                at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:593)
                at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:346)
                at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:438)
                at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:379)
                at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:225)
                at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:151)
                at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBean(AbstractKernelDeployer.java:291)
                at com.bladelogic.app.service.bootstrap.ServiceBeanXMLDeployer.deployBean(ServiceBeanXMLDeployer.java:38)
                at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deployBeans(AbstractKernelDeployer.java:261)
                at org.jboss.kernel.plugins.deployment.AbstractKernelDeployer.deploy(AbstractKernelDeployer.java:117)
                at org.jboss.kernel.plugins.deployment.xml.BeanXMLDeployer.deploy(BeanXMLDeployer.java:91)
                at com.bladelogic.app.service.bootstrap.ServiceBootstrap.deploy(ServiceBootstrap.java:240)
                at com.bladelogic.app.service.bootstrap.ServiceBootstrap.deployService(ServiceBootstrap.java:187)
                at com.bladelogic.app.service.bootstrap.ServiceBootstrap.bootstrap(ServiceBootstrap.java:141)
                at org.jboss.kernel.plugins.bootstrap.AbstractBootstrap.run(AbstractBootstrap.java:91)
                at com.bladelogic.app.service.bootstrap.ServiceBootstrap.startup(ServiceBootstrap.java:66)
                at com.bladelogic.mfw.fw.BlManager.startWithType(BlManager.java:576)
                at com.bladelogic.mfw.fw.BlManager.startWithUtilType(BlManager.java:686)
                at com.bladelogic.content.ContentMain.main(ContentMain.java:64)
            [17 Sep 2010 11:57:00,953] [main] [INFO] [::] [] Starting Task Scheduling Service...
            [17 Sep 2010 11:57:00,953] [main] [INFO] [::] [] Task Scheduling Service started.
            [17 Sep 2010 11:57:00,968] [main] [INFO] [::] [] Registering remote services...
            [17 Sep 2010 11:57:00,968] [Thread-0] [INFO] [::] [] Undeploying
            [17 Sep 2010 11:57:00,984] [Thread-0] [INFO] [::] [] Stopping task scheduling service...
            [17 Sep 2010 11:57:00,984] [Thread-0] [INFO] [::] [] Task scheduling service stopped.
            [17 Sep 2010 11:57:00,984] [Thread-0] [INFO] [::] [] Stopping Session Service...
            [17 Sep 2010 11:57:00,984] [Thread-0] [INFO] [::] [] Session Service stopped.
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Shutting down Caching Service...
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Caching Service stopped.
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Shutting down Sizing Service...
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Caching Sizing stopped.
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Stopping Port Provider...
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Port Provider stopped.
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Stopping Non-Network Management Service...
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Non-Network Management Service Stopped.
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Stopping Non-Network Directory Service...
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Non-Network Directory Service Stopped.
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Stopping Model Graph Service...
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Model Graph Service stopped.
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Stopping Configuration Service...
            [17 Sep 2010 11:57:01,000] [Thread-0] [INFO] [::] [] Configuration Service stopped.

            • 3. Re: Can't authenticate after BL upgrade
              Naveen Anne

              You didn`t finish the post migration step. If your server is windows, you have to run postmigration.exe or for unix, you have to run postmigration.sh file after the upgrade is complete. This file can be found in  -

              Windows - <BMC_INSTALL_DIR>/bin

              UNIX -  <BMC_INSTALL_DIR>/bin

              Look at Page#58 in BladelogicInstallationGuide for details on running the file.

              • 4. Re: Can't authenticate after BL upgrade
                Mike Reider

                thank you that was it! I missed the postmigration step. After I ran the exe the connectivity works.