3 Replies Latest reply on Jul 21, 2010 3:51 PM by Bill Robinson


      I'm trying to tail my pxe.log for troubleshooting and the PxeServerMonitor is driving me batty.  It chimes in every 15 seconds with 4 lines of information about active threads and free JVM memory.


      Is there a way to tune this chatiness down/off?

        • 1. Re: PxeServerMonitor

          The PxeServerMonitor thread is controlled by the same pieces that run the rest of the PXE server logging unfortunately. Because of this I can't get you a specific config that will explicitly turn it off... Your only real option is to adjust the default PXE logging level in the <install_dir>br/deployments/_pxe/log4j.properties file to a different level which would omit these messages. This change, however, would also hide most of the useful information you'd want to see like the PXE server responding to boot requests for example.


          As a workaround, why not implement something like this via NSH:

          tail -f pxe.log | grep -v PxeServerMonitor


          Which would leverage the grep utility to hide those lines...

          • 2. Re: PxeServerMonitor
            Bill Robinson

            Will log4j take logging to a pipe?

            • 3. Re: PxeServerMonitor

              I'd figured on using the pipe for the command window.  I was kind of hoping there would be some easy setting somewhere that would keep it out of the log for good.  I appreciate the insight.