2 Replies Latest reply on Apr 29, 2011 4:56 AM by Reinhard Vielhaber

    Yet another fileserver licensing question

      Here's a variation on a theme I've seen come up in the discussion forum from time to time.


      I've got a BladeLogic 8.0 installation on Linux runnig with the fileserver configured to be the same machine as the appserver. I've installed an eval license on the appserver good until October of this year. When I try to start the appserver, it fails complaining that the fileserver is either not specified or isn't licensed.


      I think the fileserver is licensed. Like I said, I've installed an eval license using putlic and I've verified the license.dat file is in the /usr/lib/rsc directory of the fileserver/appserver.


      I've used blasadmin to see if the fileserver is specified and it is. It has the FQDN of the fileserver/appserver and the correct path to the filestore on the filesystem.


      I noticed that blasadmin reports the FQDN of the fileserver while I used the hostname to generate the license. I tried using the hostname only in blasadmin to specify the fileserver but that didn't make any difference.


      I've tried stopping and starting the rscd agent and the entire server to no avail.


      The process spawner is running. I'm able to start and stop that fine using the blprocserv init script.


      The fileserver/appserver isn't in DNS. I've got the IP mapped to the FQDN and the hostname in the /etc/hosts file of the fileserver/appserver. The nsswitch.conf file specifies to look in files first then DNS for host information.


      I really don't know why the appserver is complaining. Anyone have any ideas?