11 Replies Latest reply on Jun 8, 2010 1:24 PM by Chris NameToUpdate

    Gentoo boot file error?

      I'm trying to provision Oracle Enterprise Linux 5.4 64 bit, which is RHEL under the hood.  I'm currently trying to get my boot file working properly.  I first attempted to create a 64 bit boot file.  I had to deviate slightly from stock documentation.  I've noted changes I made to the process here:




      But to boil it down, the script couldn't find "bashrc" so I changed a directory in the script and it worked.


      I copied the gentoo and gentoord.gz files back to the appropriate folder in my TFTP server.  I booted my target machine.  It loaded the gentoo and gentoord.gz files.  It scrolled and loaded a bunch more stuff and then it hit the error that I've attached as a screen shot.


      Thinking my problems were somehow related to the posted I linked to earlier, I decided to build a 32 bit boot file just to test my environment and see if I could work around 64-bit strangeness.


      I built a 32 bit image and dropped it in the appropriate TFTP server.  I booted off of the 32 bit gentoo files and ran into the exact same error as the 64 bit boot files.  (attached image.)


      I followed the BMC documentation to the letter on the 32 bit build.  What am I doing wrong?  Has anyone seen this error?  Any help is greatly appreciated.  (This environment is currently provisioning Windows machines correctly.)



        • 1. Re: Gentoo boot file error?
          Bill Robinson

          if you're not doing any pre-install scripts, you should be able to boot to winpe, have bmi auto-register the system, then provision linux onto the system and choose the boot image of 'skip linux pre-install'.  this will avoid gentoo all together.

          1 of 1 people found this helpful
          • 2. Re: Gentoo boot file error?

            That sounds like something I'd like to try.  I've followed you all the way to "choose the boot image of 'skip linux pre-install'.  When I select "Provision" and then my System Package, it automatically fills in the "Select Boot Image" drop down with gentoo32.


            I tried creating a new boot image that was blank, which ended badly.  I then gave it generic boot images to work with which also ended badly.


            How, exactly, do I deal with the "Associated Boot Image" section?  I appreciate your input.

            • 3. Re: Gentoo boot file error?
              Bill Robinson

              There's a hotfix for 7.6 that enables the 'skip linux pre-install' as a boot image type.  there's a sql script you run in addition to applying the hotfix.  Open a ticket w/ support and they can get you the latest hotfix for 7.6.

              1 of 1 people found this helpful
              • 4. Re: Gentoo boot file error?

                I'd like to pick this thread back up with the idea that patching is impossible (for now).  We've run into issues with patch 224 and would very much like to stay at 115 for the time being.


                I've cleared the problem mentioned above in this thread by downgrading the version of the Gentoo Minimalist ISO to a 2007 version that uses SquashFS 3.0. The "mkgen2img.sh" script executes cleanly without modifications now.


                During the boot process with the newly generated boot images, it passes the previous error spot and lands into a "Welcome to BMC BLadelogic Provisioning" screen.  It appears to fiddle around with eth0 for a bit and sends some DHCPINFORM and DCHPDISCOVER packets.




                The target device and boot process then hangs on the DHCPACK responses.




                Has anyone seen this behavior before or have an idea on where to begin troubleshooting?  Quick looks at my DHCP log, PXE log and TFTP log did not reveal any obvious errors.  As always, all input is greatly appreciated.

                • 5. Re: Gentoo boot file error?
                  Bill Robinson

                  There's a 228 hotfix that resolves the issue introduced w/ 224.  There's also hotfixes for bmi, (the provision files), that you might want to use to regenerate the image.  i've seen the 1st error, that is usually ok, not sure about the 2nd.  setup snoop and see if traffic is going to the right places.  you've got the dhcp options setup right?

                  • 6. Re: Gentoo boot file error?

                    I generated this boot image with the 223 revision provisioning files.


                    This environment will provision a Windows machine just fine, so I'm assuming my DHCP scope options are also fine for Linux provisioning.


                    211 = <Application Server IP>

                    212 = 0x2667 (9831 in hex)

                    60 = PXEClient


                    (This thread is not "Answered"...I hit the wrong button when trying to reply and now I can't "un-Answered" it.)

                    • 7. Re: Gentoo boot file error?
                      Bill Robinson

                      maybe gentoo doesn't like the nic?  can you ctrl-c out when you get those dhcpdiscover messages and do a 'ifconfig -a' and some other network troubleshooting to see that it's on the network, can talk, etc?

                      • 8. Re: Gentoo boot file error?

                        ifconfig -a reveals that the target device has been assigned the proper IP from the DHCP server. (Address pool: - .224)


                        Target Device:


                        IP =

                        BCAST =

                        Mask =


                        PXE Server = (

                        APP Server = (


                        I can ping FROM the target device TO the PXE server and vice versa when I CTRL-C at dhcpdiscover messages.  I'm still working on getting snoop up and running, but I'm not seeing anything wrong with the network.  Both devices are on the same VM network, etc.

                        • 10. Re: Gentoo boot file error?
                          Bill Robinson

                          tcpdump should be in the gentoo image.

                          • 11. Re: Gentoo boot file error?




                            This error is due to Oracle Enterprise Linux not having any support for the VMXNET NIC.  The Gentoo file boots as expected, but as soon as it transfers control to the OEL kernel, this hang produces.