0 Replies Latest reply on Mar 1, 2010 8:18 AM by Gerardo Bartoccini

    HP-UX VPC 7.6 Patching: Number of installed patches missing in Reports

    Gerardo Bartoccini

      Hi,

      I don't see many discussions about HP-UX patching here.

      This may be due to two alternative reasons:

      1) HP-UX VPC Patching solution works well

      2) not many people use it

      :-)

       

      Anyway, we just setup HP-UX VPC and we discovered some data is missing in reports.

      Since we found a workaround which has been now filed as RFE and will be possibly included in one of the future releases,

      I want to share it as it may hopefully help someone out there.

       

      This is a screenshot of the reports BEFORE our workaround:

       

      Before_FIX.jpg

      The number of installed patches is missing, which leads to no percentage available, as it's missing_patches/installed_patches.

       

      This is a screenshot of the reports AFTER our workaround:

       

      After_FIX.jpg

      Here's the modification we put in place in our VPC 7.6 scripts:

       

      hpc.pl

      Line

      Before

      After

      1057a1061,1062

      my   $num_of_installed_patches=$#installedPatches+1;

      print "DEBUGGING Num of   installed patches: $num_of_installed_patches\n";

      1125a1131

      $servers{$host}{num_installed}=$num_of_installed_patches;

      1244a1251

      $servers{$host}{num_installed}=$num_of_installed_patches;

      hpReports.pm

      Line

      Before

      After

      69c69

      print PSOUT   "$targetServer$fieldSeperator$fieldSeperator${$servers{$targetServer}}{num_missing}$fieldSeperator$siteName$lineSeperator";

      print PSOUT   "$targetServer$fieldSeperator${$servers{$targetServer}}{num_installed}$fieldSeperator${$servers{$targetServer}}{num_missing}$fieldSeperator$siteName$lineSeperator";

       

      Hope this helps

      Regards

      G=