8 Replies Latest reply on Jan 19, 2010 7:48 AM by Bill Robinson

    Agent upgrade failing

    Naveen Anne

      I am trying to upgrade RSCD agents from 7.4.1 to 7.6.194

      I followed the instructions in the doc and created the silent response file and then created a file deploy job and executed it.

      Here is the stack trace from the job run:


      Info        Jan 14, 2010 3:05:53 PM Exit Code 0

      Error      Jan 14, 2010 3:05:52 PM The system cannot find the path specified.

      Info        Jan 14, 2010 3:05:52 PM + /c/tmp/job_7.6_postcmd.bat

      Info        Jan 14, 2010 3:05:50 PM Copy //dev-p1app-01/C/BL-Software/instblrscd.bat -> /c/tmp/instblrscd.bat ... Done

      Info        Jan 14, 2010 3:05:50 PM Copy //dev-p1app-01/C/BL-Software/wait.bat -> /c/tmp/wait.bat ... Done

      Info        Jan 14, 2010 3:05:50 PM Copy //dev-p1app-01/C/BL-Software/RSCD760-194-W32.EXE -> /c/tmp/RSCD760-194-W32.EXE ... Done

      Info        Jan 14, 2010 3:05:38 PM Copy //dev-p1app-01/C/BL-Software/76194upgrade.iss -> /c/tmp/76194upgrade.iss ... Done


      Earlier, I tried it without wait.bat and instblrscd.bat and it stops with the same "system cannot find the path specified" error. The agent is not upgraded although files are successfully copied over the end point.

        • 1. Re: Agent upgrade failing
          Bill Robinson

          I don't see the rscd.bat or wait.bat referenced in the install pdf.  What is the actual agentctl command you are running?

          • 2. Re: Agent upgrade failing
            Naveen Anne

            Nevermind about wait.bat or instblrscd.bat. I created them to make sure there is enough wait period between the copy operation and instal operation.

            Even without those two files, i run into the same error message.

            The actual agentctl command is as shown below:


            "D:\Program Files\BMC BladeLogic\RSC\agentctl" -b exec C:\tmp\RSCD760-194-W32.EXE -a -s -f1C:\tmp\76194-upgrade.iss

            • 3. Re: Agent upgrade failing
              Bill Robinson

              and you have verified all of those paths? i'd bet that one of those is wrong...

              • 4. Re: Agent upgrade failing
                Alessandro Iacopetti

                by reference, in my upgrade jobs i use the following post command


                "%PROGRAMFILES%\BladeLogic\RSC\agentctl" -b exec "C:\temp\RSCDwindowsagent-release_7.6.0_hotfix-132.EXE" -a -s -f1"C:\temp\win32-upd.iss" /NONETSTAT


                i think the 7.4 version still used the BladeLogic directory, not the "BMC BladeLogic" one

                and if your 7.4 agents come from upgrade of previous versions this is even more true


                by switching path from "BladeLogic" to "BMC BladeLogic" BMC has done more harm than good

                vanity kills :-)

                • 5. Re: Agent upgrade failing
                  Gerardo Bartoccini

                  I am attempting to put in place your recommendations about pskill.


                  However, pskill prompts an acceptance message at the time of first execution, which basically prevents pskill to be used via BL.

                  The job hangs just after logging:


                  Error    Jan 19, 2010 10:40:57 AM    PsKill v1.12 - Terminates processes on local or remote systems
                  Error    Jan 19, 2010 10:40:57 AM    Copyright (C) 1999-2005  Mark Russinovich
                  Error    Jan 19, 2010 10:40:57 AM    Sysinternals - www.sysinternals.com


                  I have checked the registry, and I have seen the following keys are added when accepting the license agreements:






                  The first one is not something we can access via BladeLogic, as it's a dinamic folder created for any logged user.

                  The second entry is available, but I assume the logged user ClassID must be known.


                  Has anybody overcome this issue?

                  • 6. Re: Agent upgrade failing
                    Paul Seager-Smith



                    the second entry in the registry is the same as the first. HKEY_CURRENT_USER is a pointer for the logged in user to the entries in HKEY_USER - the long ID is the GUID of your user.


                    RSCD runs as the local system user in Windows, which does also have an HKEY_CURRENT_USER entry. If you are running pskill through Bladelogic, then you should be able to  update HKEY_CURRENT_USER for the Local system user. I thought that Bladelogic could update this registry tree directly. Alternatively, have you tried using regedit in a batch file to update it?


                    I am a little surprised that pskill requires that you confirm the EULA and doesn't give you a command line option to do so, but that's probably Microsoft's lawyers at work!





                    • 7. Re: Agent upgrade failing
                      Bill Robinson

                      you should be able to pass a /accepteula or -accepteula to the command.  you could alternatively push a registry key that marks the eula as accepted.

                      • 8. Re: Agent upgrade failing
                        Gerardo Bartoccini

                        pskill /accepteula works fine.


                        So I am running the following as a post-command:


                        C:\Temp\pskill.exe /accepteula rscd.exe
                        "C:\Program Files\BMC BladeLogic\RSC\agentctl.exe" -b exec
                        C:\Temp\RSCD760-194-W32.EXE -a -s -f1C:\Temp\upgrade760-194-32.iss


                        There are still lots of problems, probably because rscd.exe is not the only process that locks files.