5 Replies Latest reply on Dec 23, 2009 10:33 AM by Adam Bowen

    Compliance fails when checking Registry Value that has Newline Character?

    Vinnie Lima



      We have a compliance run against a component template which has a registry value as a part.  The value contains the log-on banner displayed to users logging onto a Windows 2003 server.


      The banner has newline characters embedded so the banner looks like this:


      You are consenting to logging on blah blah. You consent to:


      --- blah blah 1

      --- blah blah 2


      and so on.


      When creating the Compliance rule, I have the Rule Definition as follows:


      Selection Criteria - Type of Registry Value and Wildcarded Path is the path to the registry key.

      Compliance Criteria - At least ONE object must exist on target AND all objects must match the additional criteria below.  Criteria is:


      String Value (Windows) equals <pasted here>


      Where <pasted here> is literally copy and pasting the registry value for a sample target server into the value.


      But when I run the discovery/snapshot and then compliance, the rule fails.  I confirmed that its the same characters, but the target system has newline characters whereas the compliance rule doesnt.  I've tried changing the Selection Criteria to "contains" instead of "equals" and no difference in result.


      Does anyone have a suggestion for checking this?