6 Replies Latest reply on Nov 2, 2010 8:14 AM by Lee Harris

    java.lang.NullPointerException when trying to add a server



      Just for my own sanity... I'm not doing something stupid here am I? Had a server added to configuration manager (7.6.00 hotfix 189) which I decommissioned via the CM GUI. I've then tried to add the server back into CM (following a rebuild - this is a VM, so it's IP and MAC have changed but it's hostname is the same) via both BLCLI and the GUI and both throw up the error message....


      "Command Execution Failed. com.bladelogic.mfw.util.BlException: com.bladelogic.app.service.agentservice.AgentConnectionException: com.bladelogic.app.remote.BlRemoteException: org.apache.xmlrpc.XmlRpcException: Send headers caught exception java.lang.NullPointerException".


      I've tried running a BLCLI Delete performFullCleanup, updateDeleteDependencies, and cleanupDatabase as well as running ipconfig /flushdns (this is a Win2K3 appserver) but each time I get the same error.