3 Replies Latest reply on Mar 29, 2010 8:42 AM by Bill Robinson

    RedHat repository maintenance

    Craig Dockter

      Trying to use BladeLogic Red Hat Repository Manager and Downloader version 7.4.3.C1.08 to maintain our RedHat repositories with the latest RPMs from RHN. We need to go through a proxy to get to the internet. I can connect to RHN and get a list of the channels successfully.


      But if I use -createUpdateRepository to update an existing repository I get a lot of messages in the RepositoryManager.log like this:


      2008-10-02 04:12:56,508 INFO - Proxy: realProxyName:3128

      2008-10-02 04:12:56,807 WARN - Cookie rejected: "JSESSIONID=D295A85721527503B94BF55031A83B17". Illegal path attribute "/rhn". Path of origin: "/rpc/api"


      And the job hangs and eventually times out if I run it as a scheduled NSH job.

      It's interesting that it does download the latest RPMs though.



      I've also tried running the -checkUpdatesForChannel and -downloadPackagesUsingList commands. the checkUpdates runs successfully and creates the files in the documentation. The problem is it identifies packages that have already been downloaded and added to the repository. Even after the repodata directory has been removed completely and rebuilt. The downloadPackages command tells me the package exists and was skipped. The Patch Analysis job does include the skipped RPM. Here is the example:



      1. ls -l /app/nsh/storage/patchrepository/redhat/EL5.2/rhel-i386-server-5/pam_krb5-2.2.14-1.el5_2.1.i386.rpm

      -rw-rr 1 bladmin bladmin 128329 Oct 3 03:43 /app/nsh/storage/patchrepository/redhat/EL5.2/rhel-i386-server-5/pam_krb5-2.2.14-1.el5_2.1.i386.rpm


      1. ls -l /app/nsh/storage/patchrepository/redhat/EL5.2/rhel-i386-server-5/repodata/header.info

      -rw-rr 1 root bladmin 177363 Oct 3 10:45 /app/nsh/storage/patchrepository/redhat/EL5.2/rhel-i386-server-5/repodata/header.info



      1. ls -l rhel-i386-server-5/rhel-i386-server-5_listOfNewPackagesSummary.txt

      -rw-rr 1 root root 851 Oct 3 11:13 rhel-i386-server-5/rhel-i386-server-5_listOfNewPackagesSummary.txt



      1. cat rhel-i386-server-5/rhel-i386-server-5_listOfNewPackagesSummary.txt



      Channel label :--> rhel-i386-server-5

      New Packages found :--> 1

      Generated on date : 10-04-2008


      Package Id - Package Name - Package Release Date - Package Summary


      458990 - pam_krb5-2.2.14-1.el5_2.1.i386.rpm - 2008-10-02 09:57:06 - A Pluggable Authentication Module for Kerberos 5.



      1. ./RedHatRepositoryManager.sh -downloadPackagesUsingList rhel-i386-server-5/rhel-i386-server-5_listOfNewPackagesForDownloading.txt /app/nsh/storage/patchrepository/redhat/EL5.2/rhel-i386-server-5

      Previous cached credentials Found...

      Downloading the Packages [ Downloading pam_krb5-2.2.14-1.el5_2.1.i386.rpm at /app/nsh/storage/patchrepository/redhat/EL5.2/rhel-i386-server-5

      pam_krb5-2.2.14-1.el5_2.1.i386.rpm already exists at /app/nsh/storage/patchrepository/redhat/EL5.2/rhel-i386-server-5/pam_krb5-2.2.14-1.el5_2.1.i386.rpm...Skipping download.

      ] List of packages downloaded successfully...



      So at 03:43 the RPM was downloaded, the header information was rebuilt at 10:45 but at 11:13 the checkUpdatesForChannel still shows a file needing to be downloaded. Or am I missing something here?




      Craig Dockter

      Noridian Mutual Insurance Company