3 Replies Latest reply on May 23, 2008 9:40 AM by John van Ommen

    BLAST Copy Failed

      <font color="black" size="2" face="helvetica">I ran into a deploy issue today, then found a work around for it. In case anyone else sees this, thought I'd post the work around<BR><BR>


      Basically I have a deploy job which includes five "custom software" packages. Each package simply copies a file off of a directory on a managed server to another managed server. I'm running BL 7.4.2 on a Linux app server. Simple right?<BR><BR>


      What I found is that the deploy job would throw an error stating "BLAST copy failed" if the deploy job included more than one software package. The error was very reproducible; if there's one package it works, if there's two or more it fails.<BR><BR>


      The fix is simple - just use lots of deploy jobs, each with a single package. I'm posting this in the patch forums as I found a ticket which references the same error during patch deployment, ticket 24896.<BR><BR>


      Curious to fix the problem, I examined the XML which defines the package inside of the depot. At this point there were two jobs. One worked, and one didn't. One had seven packages, the other had one. Using diff I compared the "1.xml" file which defines each package, and they were completely identical. The bldeploy.xml for each was different, as you would expect, but the lines relating to each package were identical.<BR><BR>


      Here's the data:<BR><BR></font>

      <font color=#8A4117 size="2" face=Courier>

      root@someserver# ls -l<BR>

      total 32<BR>

      -rwx------ 1 root root 719 May 22 21:48 1.xml<BR>

      -rwx------ 1 root root 594 May 22 21:48 2.xml<BR>

      -rwx------ 1 root root 627 May 22 21:48 3.xml<BR>

      -rwx------ 1 root root 635 May 22 21:48 4.xml<BR>

      -rwx------ 1 root root 645 May 22 21:48 5.xml<BR>

      -rwx------ 1 root root 613 May 22 21:48 6.xml<BR>

      -rwx------ 1 root root 709 May 22 21:48 7.xml<BR>

      -rwx------ 1 root root 1710 May 22 21:48 bldeploy.xml<BR>

      root@someserver# cat ?.xml | grep "<DataFilePath>"<BR>










      <font color="black" size="2" face="helvetica">

      One thing I noticed is that the <I>DataFilePath</I> tag was different for each package. The use of this tag makes sense if your file lives in the depot, but if you're pulling the file directly off another server, then copying it to the depot, could the varyiance in DataFilePatch trip up the deploy job?<BR><BR>


      That's my hunch - I've opened ticket 26227 to have it researched. In the meantime, the workaround above will get your job working.<BR><BR>


        • 1. Re: BLAST Copy Failed

          Forgot to mention - there's an error in the logs which indicates that the job is trying to change directory to the where our file is. And of course, it can't, it's not a directory! That's one piece of the puzzle which made me think the various DataFilePaths are significant to this.

          • 2. Re: BLAST Copy Failed
            Bill Robinson

            what is BLAST for? and is it used on windows and unix ?

            • 3. Re: BLAST Copy Failed

              IIRC, blast is a new feature in 7.4.x. There's nothing about it in the docs, but I looked throught the tickets and found this:


              another parameter that you can use in blast.cfg is CACHE_DIR, which defaults to the install dir, on Unix, or under the user's "Application Data" folder, on Windows.

              Please let me know if you have any further question.

              Sent: 05/19/2008 08:05:31

              Subject: BladeLogic Ticket #25937


              blast.cfg is used by blast, a utility invoked when copying data from the source repository to a remote target or repeater.

              Blast keeps a cache locally of the data it is currently copying during the copy.

              blast.cfg contains 2 parameters by default, which is the cache size for both copying and mounting from remote at staging.

              The CACHE_SIZE should be big enough for containing all the data which is being copied. It defaults to 1000 MB, you should normally not need to change that value.

              The MNT_CACHE_SIZE is smaller as it just keeps track of the checksum of the files, not the files themselves.

              Gesendet: Freitag, 16. Mai 2008 04:28

              An: support@bladelogic.com

              Betreff: Re: BladeLogic Ticket #25937 - Question about blast.cfg file

              My customer is planning on setting something specific.

              Could you escalate this to Level 2?

              From: support@bladelogic.com

              Sent: 05/15/2008 10:32:53

              Subject: BladeLogic Ticket #25937 - Question about blast.cfg file

              I checked for documentation on blast.cfg, but so far there is no released doc. Are you planning on setting something specific? If you would like me to escalate this to Level 2 please let me know.

              Thank you

              Kind regards

              Support Team

              BladeLogic Inc.

              "Configuring the Data Center" (tm)

              10 Maguire Road, Building 3, Lexington, MA 02421



              781.257.3500 | 866.417.2600


              Ursprüngliche Nachricht-----

              Gesendet: Dienstag, 13. Mai 2008 09:37

              An: support@bladelogic.com

              Betreff: Question about blast.cfg file.

              Hello BladeLogic Technical Support,

              I'm writing this to ask you about blast.cfg file under /usr/nsh folder.

              I found blast.cfg file under /usr/nsh folder.

              However I can't find the detail in your documents.

              Please let me know the following about blast.cfg.

              What purpose does this file use?

              Is it possible for me to change these parameter?

              If it is possible, please let me know the detail of each parameter.

              Application Server:

              OS: Red Hat Enterprise Linux ES 4.0 update 5

              DB: Oracle 10.2g (Japanese version)

              BLVersion: 7.4.1

              Target Server:

              OS: Windows Server 2003 Enterprise Edition

              RSCD Version: 7.4.1