11 Replies Latest reply on Mar 26, 2014 9:43 AM by James Munoz

    Error installing RSCD agent

    Antonio Caputo

      While installing a RSCD agent 7.6 on RedHat I got the following error:




      Do you wish to use keystroke logs for nexec commands (y/n)?: n

      =============== Installing the Shared Libraries ==============


      ... Done


      ============= Checking for Random Hardware Device ============


      Found one.


      ... Done



      ===================== Installing SysInfo =====================


      Error in SysInfo installation, please check log file -> /usr/nsh/SysInfo_Install.log

      Installing yum at /opt.

      Yum installation successful at /opt




      Checking the SysInfo_Install.log I see:



      https://communities.bmc.com/root# cat /usr/nsh/SysInfo_Install.log


      MagniComp SysInfo runtime with no User Interface version 8 H43 for linux-x86

      Self-extracting Archive


      Verifying archive integrity ... OK

      Extracting tools and data image ... OK

      Extracting data /usr/nsh/nativetool_installer/sysinfo_installer: line 604: ./makeselftools/bzip2: Permission denied

      /usr/nsh/nativetool_installer/sysinfo_installer: line 604: ./makeselftools/tar: Permission denied


      /usr/nsh/nativetool_installer/sysinfo_installer: line 619: ./setup: No such file or directory

      The program returned an error code (127)

      Removing temporary files ...




      I think it's a problem related to the server, but it's hard to parse the RSCD.sh file to understand what is happening.

      Also trying to install an RSCD 7.5 the same happen.

        • 1. Re: ff

          I just noticed that my RSCD agents are installing and having the same issues. Did you ever figure this out?

          • 2. Re: ff
            Joe Piotrowski

            What installer are you using and what is the OS you're installing on?

            • 3. Re: ff

              RHEL 5.9...using RPM installer. Would a unmask cause the issue? Noticed umask was set to 0077. So I set umask to 0022 like it should be but the installer still gives bzip2 permission denied when it tries to install "native installer". I'm on 8.3 SP2. Application server, console and agents are all same version. The bash script gives same error. Selinux is off....IP tables/ip6tables is off and I can validate server/agent from console. I also get permission denied when I try to patch analyse any of my RHEL 5/6 systems. Is there anyway to debug a patch analysis job? Agent debug doesn't really give me good information as far as I can tell. Im thinking RSCD "native installer" and patch analysis "permission denied" are related. Also, I have automation principles setup. Could that be a possibility?

              • 4. Re: ff

                One last thing....I'm executing RSCD install from /tmp

                • 5. Re: Error installing RSCD agent
                  Joe Piotrowski

                  The more info you can give us, the better. I'm assuming you're attempting to install the agent through the BSA console. Is this a new install or an upgrade? How are you deploying this? As a File Deploy, Software Deploy, BLPackage Deploy, Agent Installer Job? And yes, the Role and user you are mapping to (root, domain account) will also impact how the agent gets installed. Are you using an AP and leveraging a service account?

                  • 6. Re: Error installing RSCD agent

                    Using both users.local and AP. Trying to install manually using root

                    account through SSH terminal.

                    • 7. Re: Error installing RSCD agent
                      Joe Piotrowski

                      OK, so let's simplify.

                      You're logged in as root on a RHEL 5.9 server?

                      You have the rpm installer (RSCD83-SP2-LIN64.rpm) in /tmp?

                      Does the md5sum = c058fd310c8766234d6013993c54e9eb ?

                      What command are you running to install it?

                      What error does it throw?

                      What are the contents of the install log file?

                      • 8. Re: Error installing RSCD agent

                        I have not checked the md5 value. The command I'm running is rpm -Uvh

                        RSCD83-SP2-LIN64.rpm. Everything installs without any errors but when I

                        look in the /opt/BMC/bladelogic/RSCD/SysInfo_Install.log I see an error

                        saying something about nativeinstaller failed - bzip2 permission

                        denied....Im not at work any longer?

                        • 9. Re: Error installing RSCD agent
                          Bill Robinson

                          can you attach the SysInfo_install.log ?


                          also can you attach the log message that you get w/ the patching job ?

                          • 10. Re: Error installing RSCD agent

                            I figured it out...


                            I changed my umask to 0022, but that did not fix my problem. It's actually set in two places: 1) globally set in /etc/profile and 2)set in each users profile $USERHOME/.bash_profile.


                            I then extracted the RPM and tried to execute part of the files using the debug feature of bash:


                            /bin/bash -x /native_installer/sysinfoinstaller and noticed that I was continuing to get "permission denied" erros when the "native installer" component was executing. I didn't realize how many applications use the /tmp directory to perform certain portions of the main installation.....so I asked myself why multiple occasions of disparate applications continued to give "permission denied" errors......


                            So I check /etc/fstab and noticed that the "noexec" option was set on the /tmp partition.....


                            So I edited the /etc/fstab configuration file and removed the "noexec" option for /tmp and issue the following command to remount the /tmp directory:


                            # mount -o remount,nodev,nosuid /tmp

                            ***nodev/nosuid may not apply to anyone elses environment...you have been warned!


                            After I removed the BladelogicRSCD rpm agent and reinstalled, I now check the /opt/bmc/bladelogic/RSCD/SysInfo_Install.log and everything shows as being installed correctly.

                            • 11. Re: Error installing RSCD agent

                              Thanks Bill.