5 Replies Latest reply on Jul 30, 2009 10:03 AM by Philip Sack

    No authorization to access host

      So here I am, staring at a list of about 20 servers that have this error when attempting to connect to them. I have tried just about everything I can think of to try cleaning up this issue, even reinstalling and therefore resetting all client side permissions in the process.


      Using 7.4.5 agent on a mix of solaris, aix, and linux platforms. I'm thinking the problem has to be on the server side with it somehow not being able to cleanly hit these limited number of clients (due to reinstalling the agents, and putting them back at a known good config like every other machine in the environment).


      However I've just hit a brick wall on this one. It shouldn't be firewall or it would just time out. It's not a licensing issue, nor should it be a client permissions issue.


      Anyone experience a similar issue and recall the fix(es) you may have used?

        • 1. Re: No authorization to access host

          Look at the /usr/nsh/log/rscd.log on the agent server while you try to connect. That may show you the issue. Also, as a test, you can add the the following line to your /usr/lib/rsc/exports file:


          • rw,user=root


          That should map all incoming connections to root, regardless of user. Then test connectivity. If it works, then you know you have a permissions issue. If not, then I would open a support ticket.

          • 2. Re: No authorization to access host

            Seeing this same behavior with a handful of Windows servers. RSCD.log on one server in question looks like this (I have sanitized server/user names and IP info):



            (using a pastebin site to avoid side-scrolling)


            The "Host not granted access" message then fills up the remainder of the log. I see at the top it says that RSCD is not licensed; I tried to license the agent using the *autolic *command, but I get the same "No authorization to access host" error.


            Is there a Windows equivalent for adding ** rw,user=root* to /usr/lib/rsc/exports? (Obviously, there is a C:\WINNT\rsc\exports file, is that the same thing?)

            • 3. Re: No authorization to access host
              Bill Robinson
              • rw,user=Administrator


              (or whatever your local administrator is named)


              and you may need to remove the 'nouser' line from the c:\windows\rsc\users file.

              • 4. Re: No authorization to access host

                before: 07/30/09 10:34:36.857 WARN rscd - 221294 59615/59615 (ENTERPRISE-LMF-Administrator:ME@LM.LMIG.COM): CM: Host not authorized


                after adjusting exports: 07/30/09 10:37:46.396 WARN rscd - 221316 0/0 (ENTERPRISE-LMF-Administrator:ME@LM.LMIG.COM): CM: Bad command ("bladmin"). Probably wrong encryption type/key


                And we go from not authorized to not licensed, so maybe my users file is out of whack... I'll push a standard copy of that and see what happens. Definately don't want exports hanging wide open like that.


                Thanks for the help!

                • 5. Re: No authorization to access host

                  Ok, root problem, DNS name resolution in the exports file... Added the IPs for the app servers, and I'll be changing the default file to stop this in the future.


                  Most of the boxes with the problem are DR, which have a different DNS setup, so it makes sense.