1 Reply Latest reply on Mar 28, 2008 8:53 AM by Bill Robinson

    7.4.1 SP1 upgrade on appserver agents

    Gerardo Bartoccini

      I have attempted to upgrade agents on appserver hosts with the r2000 installer.

       

      I get the following message:

       

      Network Shell is installed on this machine.

      to upgrade you must also upgrade Network Shell

      and this installer does not include that component.

      Please try again with a different installer.

       

      I have ran some snapshots and audit jobs against a host before and after upgrading the agent, and I have collected a list of files that get replaced:

       

      /usr/nsh/bin/rscd

      /usr/nsh/bin/rscd_full

      /usr/nsh/Install

      /usr/nsh/lib/libBLerrors.so.1.0

      /usr/nsh/lib/liblog4c.so.1.0

      /usr/nsh/lib/libnc.so.1.0

      /usr/nsh/sbin/bldeploy

      /usr/nsh/sbin/bldeploy_mountremoval

      /usr/nsh/sbin/bltargetjobmanager

      /usr/nsh/sbin/prngd

       

      I'm wondering if manually replacing the files would work.

      I have done it on a test server and it seems to be working fine.

       

      Would there be something else that needs checking?