6 Replies Latest reply on Jan 20, 2009 9:37 AM by Jesper Rellme

    Provisioning fails on target reboot

      My provisioning environment is finally configured correctly. When I boot my target machine, it eventually gets to a point where it waits for further instruction from the BMI. At this point, the device is loaded in PM and I can choose to provision it at leisure.


      When I initiate provisioning, the process continues to roll smoothly until the target machine is rebooted after creating the new partitions. I've clipped the portion of the log file that I feel demonstrates the error. I can supply the entire log as required.


      Looking at the details, I see that the partitions are created and that the "NTFS filesystem bootcode" is successfully applied. The creation of the "run once" is started and successfully completed.


      At this point, the log throws a "System error 67" Symptoms are that a network name is not found. I'm assuming this keeps a key drive from being mounted, as the log file quickly degenerates into not finding the drive, path, etc of specified resources.


      X:\Windows\system32>set MACADDR=00-0C-29-7F-C7-1A

      Info Dec 9, 2008 1:27:37 PM Completed Make Run Once
      Info Dec 9, 2008 1:27:38 PM System error 67 has occurred.

      The network name cannot be found.

      The system cannot find the drive specified.


      X:\>cd 2k3\i386
      The system cannot find the path specified.

      X:\>winnt32 /syspart:C /s:K:\2k3\I386 /unattend1:c:\BLProv\unattend.txt 1>X:\Windows\System32\BladeLogic\bin\state.res
      'winnt32' is not recognized as an internal or external command,
      operable program or batch file.


      This is the very tail end of the log. At this point, the target machine is hung after reboot complaining that the NTLDR is missing. This is expected due to the error in the log regarding not finding 2k3\i386.


      My datastore is located at c:\prov_training\win_datastore. Inside the win_datastore folder, I have the 2k3 folder. The 2k3 folder holds I386. The entire path is:




      In: Tools -> Configurations -> System Package Types : my OS installer for the package I'm using is set to "2k3" (with no quotes, of course).


      With all of this in mind, what is "system error 67" and how do I fix this problem? As always, any and all assistance is greatly appreciated.

        • 1. Re: Provisioning fails on target reboot

          This usually means that the system being provisioned can not resolve the host name of the server hosting the datastore. This is done via netbios. Are these two servers on the same subnet? Is the datastore property class setup wioth the right name?

          • 2. Re: Provisioning fails on target reboot

            This usually means that the system being provisioned can not resolve the host name of the server hosting the datastore. This is done via netbios. Are these two servers on the same subnet? Is the datastore property class setup with the right name?



            Discussing the netbios made me think about my lack of a WINS server. I’m building a test environment in a VM. Trying to keep things as simple as possible, I had not yet installed a WINS server. I have since done so and reconfigured my DHCP server to be aware of, and have scope for, my WINS server. Both my WINS and DHCP reside on the same server. All appropriate servers now have information stored within WINS.


            My provisioning server resides on ( The target machine grabs a DHCP IP of as per my scope definitions.


            My datastore property class is setup correctly, I believe. Since this is a PXE environment, I have set a user name and password on the “pxeshare” share, as per the documentation. I have checked and the share point is readily accessible from other Windows installations. Is this what you meant by “right name” for the datastore property class?


            Here comes the weird part. Let me preface this part with admitting that I am not a networking guru. I know enough about it to get around, for the most part. However, I cannot explain what I see happening. So here goes…


            I have moved all of my VM’s to “vmnet2” in my VMware setup. I have set vmnet2 to the subnet. (My personal home network is on a subnet.) When I have DHCP turned on for vmnet2 (that is, VMware is dishing out the DHCP address on POST), my target machine will grab The target machine will then go through the entire process of pxebooting, reading from TFTP, and loading into the PM until it reads “awaiting BMI next state”. I can then select it in the PM, choose to provision it, and away it goes. It starts formatting the drive as per directions from the system package. Shortly after that, a reboot is called for and my target machine loses contact with my provisioning server after reboot. It goes into the error I described above.


            Now, here’s the odd part, if I turn DHCP off in VMware such that the target machine is pulling a DHCP IP from my Win 2k3 VM, it pulls, and begins the PXE boot process but fails when it first tries to contact the TFTP server. When it does this, the TFTP log looks like this:


            [11 Dec 2008 15:04:24,781] [main] [INFO] BlTftp Server Started
            [11 Dec 2008 15:06:01,328] [Thread-1] [INFO] Received read request from /
            [11 Dec 2008 15:06:01,343] [Thread-1] [INFO] Requested filename :
            [11 Dec 2008 15:06:17,562] [Thread-1] [INFO] Received read request from /
            [11 Dec 2008 15:06:17,562] [Thread-1] [INFO] Requested filename :


            When this happens, the target machine is displaying the following in the command window:


            …blah, blah, blah…
            PXE-E32: TFTP open timeout
            PXE-T00: Could not open file C:\Program Files\BladeLogic\PXE\tftproot
            PXE-E36: Error received from TFTP server
            PXE-M0F: Exiting Intel PXE ROM.

            NTLDR is missing
            Press Ctrl+Alt+Del to restart


            When I turn DHCP back on in VMWare, my TFTP log looks like this:


            [11 Dec 2008 16:19:55,578] [Thread-1] [INFO] Received read request from /
            [11 Dec 2008 16:19:55,578] [Thread-1] [INFO] Requested filename : X86PC/pxelinux/pxelinux.0
            [11 Dec 2008 16:19:55,578] [Thread-7] [INFO] Sending file : C:\Program Files\BladeLogic\PXE\tftproot\X86PC\pxelinux\pxelinux.0
            [11 Dec 2008 16:20:11,828] [Thread-1] [INFO] Received read request from /
            [11 Dec 2008 16:20:11,828] [Thread-1] [INFO] Requested filename : X86PC/pxelinux/pxelinux.0

            *truncated…the log goes on until the error that I mentioned above post-reboot.


            Why does it go further into the process on the VMnet DHCP server than on the 2k3 DHCP server? Am I missing something critical here? Please let me know if I can provide any further information to help narrow down my culprit. As always, all assistance is greatly appreciated.

            • 3. Re: Provisioning fails on target reboot

              Alright, the fforums are acting up on me.


              But I still think you are having a name issue. I will get to your latter questions in a moment.


              In the first part of your system package, (PreINSTALL scripts) In the text area type PAUSE on the top line. Save the package then start the provisioning process again. This time during the process, the system should pause. CTRL+C to break out of provisioning. Now try map your pxestore via net use. Attach packet capture, pxeserver.log, and tftpserv.log


              As to your latter question, I would guess that the PXE scope options are not setup on your Win2k3 server. Or you maybe there is a firewall running on your 2k3 blocking the broadcast traffic of PXE? Just guesses, but these are just red herrings, stick with your above issue.


              Added the specific part was Pre Install scripts

              Message was edited by:

              Adam Bowen

              • 4. Re: Provisioning fails on target reboot
                Bill Robinson

                don't use the vmware dhcp. you need to use the windows (or linux) dhcp server and set some dhcp scope options that identify where to pull the tftp boot image from.


                and, in the PM gui, are your pxe and tftp servers setup up properly? (Tools | Configurations )

                • 5. Re: Provisioning fails on target reboot
                  Bill Robinson

                  you need to use the dhcp server on your windows VM, turn off the dhcp on vmware, and make sure it's disabled and off for that network.


                  also make sure the pxe and tftp are setup right by looking the PM gui under Tools | Configurations

                  • 6. Re: Provisioning fails on target reboot


                    You probably solved this own your own but I had the same problem in my environment and following Adam's recommendations I changed the Datastore LOCATION property to use Server IP instead of Name. This solved the problem with mapping the file repository server using name instead of ip.


                    This gave me a System error 53, network path could not be found.

                    net use k: \\bldemo\pxestore ****** /user:bldemo\joe


                    Probably not related to this problem but I also had to change the path syntax on the FULL_PATH property to:


                    /c/Program Files/BladeLogic/PXE/pxestore


                    c:\Program Files\BladeLogic\PXE\pxestore

                    in order to get the Windows provisioning to work. I think I have read that somewhere before but it is easy to forget.