1 2 Previous Next 16 Replies Latest reply on Jun 7, 2010 5:26 PM by Bill Robinson

    pxe server not answering bare metal client requests...HELP!

      Having a bit of a nightmare today. We were running provisioning across a dedicated VLAN, but have today moved onto a new VLAN. I've moved all of the physical connections of our BL servers so that each machines 1st onboard NIC (eth0 in Linux speak) is now connected to our new provisioning VLAN.


      I have setup a DHCP server on our Linux AppServer with all of the recommended settings from the Install Guide. I have then setup our FileServer (which is a separate physical machine) to run PXE bound to the interface which is connected to our provisioning LAN.


      When I try to pxe boot one of our bare metal test servers, it never gets a response from the pxe server.


      I have tried literally everything I can think of to try and get this working. I've even resorted to changing every available setting on and off and retrying the pxeboot, but still the pxeserver just doesn't bother to respond.


      When the BM client boots, DHCP answers, and according to the packet capture I'm running on the PXE server, PXE sees the DHCP packets, and some entries get recorded to the pxesvr.log file, but it doesn't respond to the BM client, so we get "No boot filename received."


      I've even tried configuring the DHCP and PXE on the same physical server, reinstalled PXE completely and so on.


      I'm at my wits end. Does anyone have any idea what might cause this?


      Thanks - Lee

        1 2 Previous Next