3 Replies Latest reply on Jul 9, 2008 12:36 PM by Valerian Jone

    Winpe 2.0 Image Getting a 169 IP Address

    Valerian Jone



      We're trying to do some windows provisioning and for some reason when the winpe 2.0 boot image loads, it initially gets a 169 IP address. If we manually do a ipconfig /renew on the console in winpe, then it gets a dhcp ip address just fine. For some reason the winpe2.0 boot image is self assigning a 169 IP address initially. But dhcp seems to be working since we can do a ipconfig /renew and get a dhcp ip address just fine and once that occurs, bmi can communicate with the app server. And also, since we're in the winpe2.0 boot image, the bare metal server is also able to get a dhcp ip during the pxe boot process to pull down the boot image itself.


      Has anybody seen this type of behavior recently? Is there any specific dhcp server setting I should check for on the dhcp server?


      This is a IBM 336 box. It has 2 active nic cards on it and only one nic card is plugged in (to the provisioning network), the other is unplugged. I'll try disabling one nic card to troubleshoot but I thought we were over those multiple nic card issues. I injected broadcom netxtreme II drivers into the boot image and that seems to work fine as well since the winpe2.0 boot image is able to recognize its nic cards.


      We're on 7.4.1 rev2001 on a win2k3 app server. We're using the latest external files and provisioning files for 7.4.1. The dhcp and pxe server are the same server.

        • 1. Re: Winpe 2.0 Image Getting a 169 IP Address

          I had a similar problem. I added a short sleep and an additional ipconfig /renew to init.bat and the problem was solved.

          • 2. Re: Winpe 2.0 Image Getting a 169 IP Address




            Maybe not in main context of your probloem, but I'd like to ask you about that IBM machine of yours. Have you had any problems booting WinPE2.0 ob IBM bare-metal? I'm trying to provision Win2003 to IBM x366 and with WinPE1.6 it's OK (I mean, regarding booting - later on we've run into the IP issue just like yours, and solved it with ipconfig /renew in win2k3.bat), but when I try to boot WinPE2.0 the bare metal only downloads bootmgr.exe from tftp and hangs - blank screen, no activity regarding bootimage downloading, nothing. As far as I can tell it may be related to a rather old bios (1.09 vs. 1.12 latest) but machine is clients' not mine in a remote datacenter so bios upgrade is not an option.


            Any advice?

            • 3. Re: Winpe 2.0 Image Getting a 169 IP Address
              Valerian Jone

              If you enable debug in your tftpsvr.cf you can see what exactly the bare metal server is pulling down, what requests and what it receives.


              Change the line:

              log4j.rootLogger=INFO, R, C



              log4j.rootLogger=DEBUG, R, C


              Check out the tftpsvr.log while you are booting the bare metal box. All files are located in the PXE/br directory. Hopefully that can help you isolate down whether or not the boot image is able to be transferred to the bare metal box or if its the winpe2.0 boot image itself that is having problems starting.