11 Replies Latest reply on Feb 20, 2008 10:11 AM by Michael White

    HS21 and WinPE

      It would appear that WinPE doesn't have appropriate drivers for the HS21s Broadcom NetExtreme II network card. When you boot an HS21 (and possibly others) and the network doesn't come up, you get an error screen (the instruction at (some address) referenced memory at (some other address). the memory could not be read. click on ok to terminate the program). This seems to be caused by the server having no IP address, because it has no network card.


      After much fiddling, I've found that the RIS drivers for the NetExtremeII work.


      I downloaded the drivers from




      The file I got for PE was "win_2k3_RIS-3.4.1.zip" (near the bottom of the page). I extracted them to c:\drivers\hs21\pe\32bit. There are 2 files: b06nd.inf and b06nd51x.sys.


      I added c:\drivers\hs21\pe\32bit\b06nd.inf to my driver.txt file and built and voila! It worked.


      Note: you cannot use the "normal" win2k3 etc drivers in the WinPE image, you must use the RIS drivers. As far as I can tell, the drivers you can download from IBM will not work - I don't see the RIS driver. You have to get them from Broadcom. The IBM supplied drivers are for when you're in the target OS (2k3, etc). If you fiddle around in WinPE, you can get them to load, but they still won't bring up the interface.

        • 1. Re: HS21 and WinPE

          I'm seeing the same exact error message trying to boot a VM image. It seems to be finding the nic correctly and getting an IP address.


          Any ideas on what else could cause this? It's a pretty unhelpful error message.

          • 2. Re: HS21 and WinPE

            Michael what version of BL are you running?

            • 3. Re: HS21 and WinPE



              Just trying to provision a Windows 2k3 image to a VM instance. At first WinPE wouldn't load because of a "no active nic found!" error. I grabbed the vmxnet.inf and vmware-nic.inf drivers from the windows.iso of a Vmware workstation install and added them to the driver.txt file and rebuilt. It got me past the original error, so that the vm image will boot and become available in provisioning manager. However, once I actually attempt to provision a system package onto the device, I receive the memory error on the target server.

              • 4. Re: HS21 and WinPE

                Can you ping the appserver? can you telnet to the port? do you have a default route?


                if you run bmi.exe again, does it crash, or keep going?



                • 5. Re: HS21 and WinPE

                  can ping the appserver. If I try telnet it says it's not a recognized command.


                  When I run bmi.exe again, it crashes with the same error.

                  • 6. Re: HS21 and WinPE

                    Are the only drivers that I would need to add to the image the vmxnet.inf and vmware-nic.inf drivers from the windows.iso?


                    Would I need anything else? I have no idea what could be causing this error...

                    • 7. Re: HS21 and WinPE

                      The last (and re-occuring) error I see the tftp log is the following:


                      File not found : C:\Program Files\BladeLogic\PXE\tftproot


                      I'm assuming that not find a font, shouldn't cause the whole thing to crash. But I could be wrong.


                      Another odd thing about this is that it's looking for this file under "/Boot" which isn't what I have BladeLogic configured to use to grab the image. It goes to right directory to find everything else.

                      • 8. Re: HS21 and WinPE

                        Is this happening during the WinPE phase still? Or are you on to the OS provisioning phase.

                        • 9. Re: HS21 and WinPE

                          Those errors are "normal", in that I saw them all the time on my instance as well.


                          If you're getting in to the winpe image, then that part of the world is working.


                          is bmi.exe crashing only in a vm, or on regular systems?

                          • 10. Re: HS21 and WinPE

                            WinPE seems to boot up fine and wait for me to provision a system package from the provisioning server, the target server console sits there with a "BMI: Get next state" message. Almost immediately after I provision the device it bmi.exe crashes with that error. I'll attach a screen shot of the console below.


                            I've only been working with VM's, unfortunately I don't have a regular system to test provisioning on.

                            • 11. Re: HS21 and WinPE

                              It actually gets past the 'ckpolicy' command now, but gives the same exact error on the next state, which is:

                              "BMI: Next state is 'switchboot'.


                              I'm not sure why ckpolicy works now. I created a new image, where I basically grabbed every single .inf I could from the vmware windows.iso, but injecting the drivers did fail for some of them, including vmx_svga.inf. The mouse and scsi drivers also errored out.