6 Replies Latest reply on Jun 10, 2005 11:16 AM by Brad Jacobs

    Provisioning RedHat ES 3 on Dell 2850

      I'm having some issues getting a Dell 2850 with a PERC 4e/Di SCSI Raid array provisioned with RedHat ES 3u3. Initially, it looked like the ethernet driver (e1000) wasn't loading, but all signs point to the driver being supported by the RH release.


      What we've done so far:


      1. Tried to boot off the standard kernel/initrd images from the Redhat ES3. This did not work. We did not see either the PERC 4e/Di array (scsi disks) or the network card. I don't know if the missing drive broke us out of the install before the network adapter was able to load. The e1000 network driver for the 2850 did seem to exist on the Redhat image.


      2. We've added the PERC driver to the initrd image according to the document written by Dan Fitzgerald. This image failed in the same manner as item #1. However, if we search for the drivers during the interactive install, the Megaraid2 driver does show up. It isn't clear whether it loads or not. I believe it did load once, but it didn't load the second time.


      3. Attempted to load the e1000 driver from the RH driver list. This didn't work.


      4. We've tried to add the e1000 driver (following our docs) to initrd, but ran into a corrupt modules.cgz. So, no access to the driver.



      Current status:


      We know if we install RHES3 onto the systems using the CD/interactive install, the install does seem to work. We've been able to get another 2850 up and running in this manner.



      Things we are going to attempt tomorrow:


      1. We will attempt to do the CD install on the box we are attempting to provision. If this works without breaking out to driver requests, we will see what we need to change in our process.


      2. I will download the DMKS app and attempt to build a new kernel with Dell's Megaraid2 and e1000 drivers. This will take a while, but it should give us a proper kernel with all the driver modules we need.


      3. If that doesn't work, I will attmept to build a kernel with SCSI support built into vmlinuz and the DMKS loaded drivers.


      4. If that doesn't work, then I will need to get the latest RedHat kernel release and build in the experimental LSI drivers (if they exist, and I think they do) and the e1000 driver.


      5. Try using the "driverdisk" option in the kickstart config file to download/install the PERC drivers.


      6. Maybe try using the latest Fedora Core 3 kernel since most experimental drivers are active on that build.


      Any suggestions would be appreciated.



      Sung Koo