5 Replies Latest reply on May 28, 2010 9:41 AM by Erica Muxlow

    PXE Service

      What are all of the requirements that need to be met in order for the BladeLogic PXE service to start?

        • 1. Re: PXE Service

          Look in the pxeserver.log. It should point you to the error. Or run the pxe server manually from the command line.

           

          1. The PXE server needs to communicate with the database. If the error points to the fact that the pxe server cannot connect to the DB, you may have the connection parameters wrong. If you have a working app server, copy the config.xml from the app server to the pxe server and try again.

           

          2. If the error points to the fact that the PXE server cannot bind it may be that the PXE server and the DHCP server are on the same physical machine. If this is the case, the PXE server must NOT be configured to listen on port 67. When installing the PXE server, the installer asks if they are to be running on the same server, and sets up the start flags accordingly. If you have answered this question incorrectly or if you have added a DHCP service since the installation, the PXE server may not be able to start up. This is because it is trying to bind to the same port on which the DHCP server is listening. To check if there is a process listening on port 67 before you start the PXE server, issue the command netstat -an.

           

          If there is a process listening on port 67, you will have to remove the startup flag which tells the pxe server to listen on port 67. This flag is located in the startup scripts and also in the Windows registry if you are running it as a service (Blagelogic->PXE->PXE Server). The flag is called -Dblx.bmlistendhcp. Remove this flag entirely, do not just set it equal to false.

           

          Try starting the PXE server again.

          • 2. Re: PXE Service

            James, you are truly the king of the PXE's!

            • 3. Re: PXE Service

              Is it possible for PXE to work intermittently even if the DHCP/PXE configuration is incorrect? I just looked at Edmunds' blpxe script and it has blx.bmlistendhcp=true and DHCP is running on the same server, but the guys were provisioning tons of servers with this configuration months ago. The only thing I can think of is that when PXE was originally installed, DHCP was off, but set to turn on at startup, and then at some point they rebooted and bam. Even then, PXE would work intermittently. The problem is fixed already, so this is not high priority, but if you can think of anything else, I'd appreciate it!

              • 4. Re: PXE Service
                R V

                ok - it's really an old one, but for future reference I just add the complete path:

                 

                holl0028 schrieb:

                 

                If there is a process listening on port 67, you will have to remove the startup flag which tells the pxe server to listen on port 67. This flag is located in the startup scripts and also in the Windows registry if you are running it as a service (Blagelogic->PXE->PXE Server). The flag is called -Dblx.bmlistendhcp. Remove this flag entirely, do not just set it equal to false.

                 

                HKEY_LOCAL_MACHINE\SOFTWARE\BladeLogic\PXE\PXE Server

                 

                 

                • 5. Re: PXE Service

                  I have a similar issue.

                   

                  The registry entry does not exist on this server. (HKEY_LOCAL_MACHINE\SOFTWARE\BladeLogic\PXE\PXE Server) Does it not exist in 8.0?