5 Replies Latest reply on Jul 25, 2008 3:20 PM by Steve Johnson

    custom command options

      Is there any way to add the "-l" option to the nexec when creating interactive custom commands? Right now, the custom command just adds the "-i" action when the command is interactive.


      Also, has anyone found a way to change the shell window used by BL for custom commands? I would much prefer cygwin's rxvt over the DOS command window.



        • 1. Re: custom command options

          Currently there is no mechanism to turn on "-l" from the custom commands definition window. The resulting "nexec" happens internally and is currently out of the end user's control. This would have to be an enhancement request.


          As far as the alternate shell window is concerned there is also no way to currently control this. This too would have to be an enhancement request.


          I suggest that you log it with technical support.

          • 2. Re: custom command options

            If you're daring you could rename cmd.exe to something else and make a copy of rxvt.exe named cmd.exe


            I'm not sure it would work, but why not give it a try?


            • 3. Re: custom command options

              You could also always run your custom command as a Local type instead of Remote and have it run "runcmd -h %H -e nexec -l -e ". That should do the trick.


              Also, be sure to include the -i in there if it's an interactive nexec (sqlplus, ksh, etc.)

              • 4. Re: custom command options

                Hi Jarrod,


                That seemed to do the trick. To wit:


                rxvt -e runcmd -h %H -e nexec -l -i -e bash


                In the BL Config Mgr, select:



                -> Custom Command Administration

                ---> Add Custom Command


                > Local


                > Name: "Open bash with rxvt (Cygwin)"


                > Command: "rxvt -e runcmd -h %H -e nexec -l -i -e bash"


                > check Servers


                > check the Operating Systems to suit your environment


                > select these Command Options:


                > Close the command window...


                > The command should open a separate window...


                > The command will execute without the option...


                That should do it!

                • 5. Re: custom command options

                  I love this idea...and I implemented it. However, in my rxvt window I can't see what I am typing (until after I hit return) and the command prompt doesn't show up. It is almost like the terminal is a line behind or something.


                  Message was edited by:

                  Steve Johnson