4 Replies Latest reply on Aug 29, 2010 3:16 PM by Paul Seager-Smith

    SQL Server 2005 installation

      I'm trying to deploy SQL Server 2005 and can run the commandline installation without any problems. When I try to run it through BL, it throws an error that indicates that the user does not have administrative privileges (must be a member of the administrators group). The job is running as BladelogicRSCD and the ACLs are set for my account to impersonate the Administrator account (I can nsh to the box and run other admin privileged commands).


      I also tried adding BladelogicRSCD to the Administrators group to see if that would resolve the issue but the same problem still occurs. any ideas on what could be causing this and what the fix would be? This is 7.0.1

        • 1. Re: SQL Server 2005 installation

          I was able to work around this issue by downloading a runas utility that allows password to be passed as part of the commandline. It's not ideal and there is additional sensitivity around password management, but it is a working solution for now:


          Be sure to include the cpau.exe utility on a specified path, or as part of the deployment package


          cpau.exe -u username -p password -lwp -wait -ex "command"


          the -lwp (with local profile) switch is required


          cpau is available at: http://www.joeware.net/win/free/tools/cpau.htm


          Other utilities that may be a possibility include lsrunas or sanur

          • 2. Re: SQL Server 2005 installation
            Mark Jeffery



            I used the sysinternals psexec utility (part of the pstools suite).


            First of all, download SQL 2005. In this case, I downloaded SQLEXPR.EXE into a directory.


            Next download pstools http://www.microsoft.com/technet/sysinternals/ProcessesAndThreads/PsTools.mspx, and extract them into the same directory.


            You should have SQLEXPR.EXE and PSEXEC.EXE in the same directory.


            Add that directory as Windows custom software.


            The install string is:


            "??SOURCE??\psexec" /accepteula -w "%CD%\??SOURCE??" -s -i cmd /c start/wait SQLEXPR.EXE /qn INSTANCENAME=MJ ADDLOCAL=ALL PIDKEY=abcdef SAPWD=password SQLACCOUNT=Administrator SQLPASSWORD=password AGTACCOUNT=Administrator AGTPASSWORD=password SQLBROWSERACCOUNT=Administrator SQLBROWSERPASSWORD=password


            The uninstall string is:


            "??SOURCE??\psexec" /accepteula -w "%CD%\??SOURCE??" -s -i cmd /c start/wait SQLEXPR.EXE /qn INSTANCENAME=MJ REMOVE=ALL


            It seems to work without requiring passwords!



            • 3. Re: SQL Server 2005 installation
              Carmine Ricci

              Hello I would really like to know how you got this to run..I'm currently having a lot of problems automating the softwate installation on a target Windows 2003 server. I think i've tried all the possible commands possible using the tool psexec. Buth the command executes perfectly when you run it manuualy on the server, but when in the context of the rscdagent it seems it does not want to execute the setup. I've tried using differnt combination of setup types.

              I've started with Windows Custom Software and now at the oint of using a BLpackage which copies the source to the local drive and then launches the setup program (both types are not working) but for now do not understand where I'm going wrong. When I look in the log file (transactions dir) , the log is at stand still when launching the command but not because there is a problem with the command setup (i know because launching it manually it works) it's because the bladelogicrscd launches the process psexec and cmd but the setup.exe process is not turning on the machine.

              • 4. Re: SQL Server 2005 installation
                Paul Seager-Smith

                If you are using 8.0, then you should really use automation principals for this. It makes it much simpler to install SQL 2005 and removes the need to use any runas or psexec workarounds.