1 Reply Latest reply on Oct 30, 2009 4:55 AM by Sonal Khosla

    Remedy C API 5.1 > 7.5

      Share:|

      Our customer has three small programs written in C++  towards their AR system Server, this is written a long time ago, with 5.1 API.  Does anyone know if this still would work with a 7.5 server? Is the C API backwards compatible?

       

      Rgds

      Caroline Jahr

        • 1. Re: Remedy C API 5.1 > 7.5

          Hi Caroline,

           

          AR System 7.5.00 is backward-compatible, supporting all requests from client applications that use the 7.1, 7.0, 6.3, 6.0, 5.1, 5.0, 4.x, or 3.2 API libraries. If you continue to link to one of these libraries, you do not need to make any changes to

          continue running your existing programs against AR System 7.5.00 servers.

           

          If you link to the new 7.5.00 API libraries, you must make changes to your programs and recompile them. The main program structure and processing, however, need not change.

           

          For more information, you can also refer C API 7.5 Reference Guide: http://documents.bmc.com/supportu/documents/53/74/95374/95374.pdf

           

          HTH,

          Sonal