5 Replies Latest reply on Jan 21, 2010 8:30 AM by Matt Gee

    ARERR [8939] - Plug-In Error & RPC Timeout

    Julian Martin
      Share This:

      Hello,

      I have a brand new ITSM 7 server + Patch 007 installed, and I keep receiving this error while I attempt to launch the Problem Management console or Foundation Elements console:

       

      Troubleshooting ARERR The AR System Plug-In server is not responding. Cannot connect to the system at this time. Contact your AR System Administrator for assistance. : RPC: Timed out


      For Incident Management works fine. I have checked the CAI Registry and there I can see Incident Management entry, but not Problem Management. However, I do not know how to fulfill the details in there.

      I read that sometimes the ardbcquery.dll may be causing this, but after installing Patch 007, I guess I have the last version of it.

      I have already tried to modify the AR.CFG file with the values indicated:

      Plugin-Default-Timeout:<your setting>

      Plugin-Loopback-RPC-Socket: <your setting>

      Plugin-ARDBC-Threads: <your setting>

      Filter-API-Threads: 1 15


      Also tried to increase the number of Fast and List Threads, but the error keep repeating.

      Any idea?

      Thx & Regards,
      J

        • 1. Re: ARERR [8939] - Plug-In Error & RPC Timeout
          Danny Kellett

          Hi,

          The error is a basic communication error. Although it says RPC timeout, its not really anything to do with remote procedure calls or threads.

          Are you running portmapper?
          Have you configured the arplugin to have a specific TCP port? lookin ar.conf for Plugin-Port. If it is there, then check that the arplugin is actually running, and then from a command line try the following

          telnet hostname tcpport

          e.g. if ar.conf says Plugin-Port: 2222

          and you are running the server on a machine called blue then

          telnet blue 2222

          If you dont get an error saying connection refused then you know its running on that port.

          If it you do get an error saying something about connection refused then you will need to comment out the arplugin line in the armonitor.conf and run it manually. Let me know if you need to do that.

          Regards
          Danny

          • 2. Re: ARERR [8939] - Plug-In Error & RPC Timeout
            Danny Kellett

            By the way I think the

            Filter-API-Threads: 1 15

            Should actually be Plugin-Filter-API-Threads: 1 15

            Regards
            Danny

            • 3. Re: ARERR [8939] - Plug-In Error & RPC Timeout
              Timo Arvola

              Hi,

              Did you get your problem solved?

              If you have a Solaris server, I think there is a bug that cai event plugin process, look CAI Events form, if there is events where Return Code is Running, delete those events and stop and start arserver again.

              -ta-

              • 4. Re: ARERR [8939] - Plug-In Error & RPC Timeout

                This is a bug related to the logging for the CAI plugin. The problem is that you don't have the updated version of Solaris CAI Plugin Lib.  I’ve attached the Solaris library for the CAI plugin that contains the fix.  I will try to attach the new version of CAI Plugin Lib, This version will run best if there is more than one thread configured for the CAI plugin.

                 

                Plese follow the below process:

                 

                 

                 

                You should see a new CAIFilterPlugin.log get created which will display the logging for the submit.  Check for any ERROR messages in the log

                 

                The latset lib would be soon be uploaded.  or it can be copied it from ITSM CAI Plugin libs

                 

                Hope this helps.

                 

                Regards,

                HB

                 

                1. Delete the entries in CAI:Events and CAI:EventParams.
                2. Bring down the plugin server.
                3. Install the new CAI library
                4. Remove the CAIFilterPlugin.log file from the /home/ARSystem/db directory.
                5. Restart the plugin server.
                6. Submit the request that causes the problems.

                 

                 

                • 5. Re: ARERR [8939] - Plug-In Error & RPC Timeout

                  Hi

                   

                  I dont see any files attached..

                   

                  Are you able to send me a link to were i can get these please?

                   

                  thanks

                   

                  Matt