5 Replies Latest reply on May 28, 2020 5:21 PM by Jason Miller

    ARERR 623

    Michael Giambrone
      Share This:

      After installing AR System 9.1.4 and installing Mid-Tier, receiving ARERR [623] Authentication failed: MidTier Service


      RSSO was not installed prior to installing MidTier.


      Logging into MidTeir Config.jsp is OK, but trying to log into ARsystem is throwing the error.

        • 1. Re: ARERR 623
          Mark Walters

          Reset the MidTier Administration Password via the server Administration Console and then use this when adding the server via the midtier config pages - see ARERR [623]  I can not login in mid tier web

          3 of 3 people found this helpful
          • 2. Re: ARERR 623
            Michael Giambrone

            Thanks Mark, my issue is I can't log in to get the the Admin Console. Is there a work around as I can't log in with my Administrator account?

            • 3. Re: ARERR 623
              Mark Walters

              Ah, the old chicken and egg problem!  Do you have access to old Remedy User Tool client?  If not you can use the driver command line API tool which will be on the server.  If you're using Windows just run driver.exe, for Linux get a command prompt in the ARSystem/bin directory and start it with _LIBRARY_PATH


              $ LD_LIBRARY_PATH=. ./driver


              Then use the following as a guide to login and make an SSI (SetServerInfo) call to reset the password - substitute your values as required...


              Your input in BOLD


              Command: log

              Control record:

                 Authentication string () :

                 User name () : Demo

                 Password () : your_Demo_user_password

                 Locale[.charSet] () :

                 Time zone () :

                 Server () : your_AR_server_name


              Command: init


                 ARInitialization  results

              ReturnCode:  OK

              Status List : 0 items


              IF your server is NOT using portmapper you need to set the port, otherwise ignore this bit

              Command: ssp

              SET SERVER PORT

              The port number of server (0): your_server_port

              Using private socket? (0):


              Make sure we have correct login details - this should return OK - if not just start again from log above

              Command: ver

              VERIFY USER


                 ARVerifyUser  results

              ReturnCode:  OK

              Admin flag:  TRUE

              SubAdmin flag:  FALSE

              Customize flag:  TRUE

              Status List : 0 items


              Command: ssi

              SET SERVER INFO

                 Number of server info operations (0): 1

              Server info list entry

              Operation (1-402) (1): 154

              Datatype Null/Key/Int/Real/Char/Diary/Enum/Time/Bitmask/Byte/Decimal/attach/


                       coords/view/display (0-14, 30-34, 40-43) (0): 4

              Char Value (): your_new_midtier_password


                 ARSetServerInfo  results

              ReturnCode:  OK

              Status List : 0 items


              Now Ctrl+C or whatever to quit

              1 of 1 people found this helpful
              • 4. Re: ARERR 623
                Michael Giambrone

                OK, Mark. I was able to change it from the config.jsp page and it worked. I'm in now.


                Thanks for your assistance.

                • 5. Re: ARERR 623
                  Jason Miller

                  I had a situation with a brand new install for a customer where there was a communications issue between the AR Server and MT. With the newer requirement login with an AR user account I had no way to login and configure MT. I was finally able to resolve the comms issue between the servers but things config-wise went a bit sideways. I just ended up running the MT installer again. Previously I would of been able to login to the MT config page to make any needed adjustments (short of tweaking the config.properties file).