1 2 Previous Next 21 Replies Latest reply on Jul 26, 2020 3:15 AM by Mohammad Jedayeh

    ITSM Deployment Failure

    Mohammad Jedayeh
      Share This:

      Hi All,

       

      I`m facing some issues when i try to deploy an ITSM package using AR System Deployment Management Console as the following:

       

      I`m facing the following error when i use ITSM 1908:

      reason.png

      so i`ve tried to deploy an old version (ITSM 1808) in which the following error appears:

      reason2.png

      Note: I`m using Version 9.1.08

      Any Help Please ?

       

      Thanks & Regards,

      Jedayeh.

        • 1. Re: ITSM Deployment Failure
          Arun Mungase

          Hi Mohammad,

           

          What is the current ITSM version you have?

          Are you doing fresh installation or upgrade? have you install ITSM 1805 before deploying ITSM 1908?

           

          -Arun M

          • 2. Re: ITSM Deployment Failure
            Arun Mungase

            Before deploying ITSM 1908 you must install ITSM 1805 using installer.

             

            Below are the steps:

            1. Install/Upgrade AR 1908 using installer

            2. Install/Upgrade Atrium Core using installer

            3. Install/Upgrade Atrium Integrator using installer

            4. Install/Upgrade ITSM 1805 using installer

            5. Install/Upgrade SRM 1805 using installer

            6. Install/Upgrade SLM  1805 using intaller       Then

             

            7. Deploy ITSM 1908 using deployment console  (Here we need to run arpayload utility to deploy binaries at last step/sequence)

            8. Deploy SRM 1908 using deployment console

            9. Deploy SLM 1908 using deployment console.

             

            Please refer below 1908 installation doc for more details:

            https://docs.bmc.com/docs/brid1908/installing-879731396.html

             

            Please let us know if its work for you.

             

            -Arun M

            1 of 1 people found this helpful
            • 3. Re: ITSM Deployment Failure
              Mohammad Jedayeh

              Hi Arun,

               

              it`s a fresh installation, i`ve tried each package separately, i mean at the beginning i tried to deploy ITSM 1908, but when it`s rejected i`ve deleted it and tried to deploy the older one.

               

              Kind Regards,

              Jedayeh. 

              • 4. Re: ITSM Deployment Failure
                Arun Mungase

                If you are doing fresh installation then please check ITSM version in "SHARE:Application_Properties"  form  its should be 9.1.05 before deploying ITSM 1908.

                 

                -Arun M

                • 5. Re: ITSM Deployment Failure
                  Arun Mungase

                  Can you please share detail steps which you have followed for fresh installation from scratch?

                   

                  -Arun M

                  • 6. Re: ITSM Deployment Failure
                    Mohammad Jedayeh

                    At the beginning i`ve prepared the system for the installation to ensure that no temporary files will be deleted and so on, then i installed the AR system through the installer (ARSuiteKitWindows9.1.08 -> Disk 1 -> Setup[as administrator]) the installation has been done without any errors or warnings.

                     

                    Then the Atrium9, Atrium integrator, ITSM suite, SRM, SLM, and Smart Reporting(With Onboarding),  everything done without any issues.

                     

                    I tried to deploy the packages at this step but the ITSM 1908, it took about two hours so i canceled the deployment, deleted it, and tried to import it and deploy it again, the error appeared here.

                     

                    Now when i tried to install the Smart IT i couldn't until i`ve deployed the SRM, and SLM packages, then the Smart IT installed without any issues, errors, or warnings, but DWP couldn't because it needs ITSM.

                    • 7. Re: ITSM Deployment Failure
                      Stefan Hall

                      Mohammad,

                      ok, you have installed the AR platform in version 9.1.08, but your next sentence puzzles me:

                      Then the Atrium9, Atrium integrator, ITSM suite, SRM, SLM, and Smart Reporting(With Onboarding),  everything done without any issues.

                       

                      I assume that you have installed ITSM, SRM, SLM in version 1805 = 9.1.05 at most. Please have a look at the Shared Application Properties. If you have installed a version lower than 1805, this would explain the error. You need exactly this version,  otherwise no higher D2P package will work.

                      1 of 1 people found this helpful
                      • 8. Re: ITSM Deployment Failure
                        Mohammad Jedayeh

                        Hi Stefan,

                         

                        Do you mean this ?

                        P1.png

                        • 9. Re: ITSM Deployment Failure
                          Stefan Hall

                          Yes, that's what I meant.  According to your picture you have already installed the D2P at least for SRM.  For ITSM and SLM as well, right?  What do these entries look like?

                          • 10. Re: ITSM Deployment Failure
                            Arun Mungase

                            Because of below step , now you are not able to deploy ITSM 1908 because you have cancelled/deleted ITSM 1908 deployment in between so version is already updated in SHARE:Application_Properties before you cancelled for ITSM.

                             

                            I tried to deploy the packages at this step but the ITSM 1908, it took about two hours so i canceled the deployment, deleted it, and tried to import it and deploy it again, the error appeared here.

                             

                             

                            -Arun M

                            2 of 2 people found this helpful
                            • 11. Re: ITSM Deployment Failure
                              Arun Mungase

                              Can you please check version of below ITSM product in SHARE:Application_Prperties? Its should be 9.1.05 before deploying ITSM 1908 D2P.

                               

                              • BMC Remedy Incident Management
                              • BMC Remedy Change Management
                              • BMC Remedy Asset Management
                              • BMC Remedy Problem Management

                               

                              -Arun M

                              • 12. Re: ITSM Deployment Failure
                                Stefan Hall

                                Arun, That was my thought too, but updating the version is the last step of a D2P package.  If you abort or rollback, there shouldn't be a wrong version there, right?

                                • 13. Re: ITSM Deployment Failure
                                  Arun Mungase

                                  Hi Stefan,

                                   

                                  We are not  updating version at last step , we are updating version component wise like, Foundation/Asset Management/Incident Management/Problem Management/Change management/Knowledge Management etc.

                                   

                                  We have total 448 items in 1908 d2p package and we are updating version after each component like below:

                                   

                                  And as Mohammad mention above he cancelled and deleted the package and we don't know at what stage he cancelled and deleted the package.

                                   

                                  I think he missed to execute payload utility at last stage thats why deployment got stuck at last stage i.e 19.08 ITSM Binaries   (448 stage), and after that he cancelled package deployment without running the payload utility.

                                   

                                  We are updating version in SHARE:Application_Properties at below stage in ITSM 1908 d2p package.

                                   

                                  Thanks,

                                  Arun M

                                  3 of 3 people found this helpful
                                  • 14. Re: ITSM Deployment Failure
                                    Mohammad Jedayeh

                                     

                                    • BMC Remedy Incident Management
                                    • BMC Remedy Change Management
                                    • BMC Remedy Asset Management
                                    • BMC Remedy Problem Management

                                    Arun Mungase

                                    All of the previous have the version 9.1.08

                                     

                                    -Jedayeh

                                    1 2 Previous Next