1 Reply Latest reply on Feb 25, 2020 12:12 PM by Volker Scheithauer

    Error while copying a file from BAO/TSO server to target server via workflow using Commandline adapter

    Yogeesh Kompa
      Share This:

      Dear All,

       

      I am developing a workflow to copy a file from my BAO server 9windows) to the target server (all windows) before running/executing the script. I am using a command line adapter and out of the box command line workflow to run the below command.

      <command>xcopy /yr D:\Workspace\sample_file.ps1  \\<target_server>\C$\tmp</command>

       

      If I run through workflow, it doesn't work and throws below error.

      <output>

                  <line index="1">Invalid drive specification</line>

                  <line index="2">0 File(s) copied</line>

      </output>

       

      I have verified the credentials (it has all relevant permission to copy as well) on target machine and it works without an issue. I have manually ran the command from BAO server using command prompt, it works and copies the file as well without any issue.

       

      The workflow successfully identifies the target server (see below).

      <target-output>

            <metadata>

              <os-id>Windows Server 2012</os-id>

              <os-version>6.3</os-version>

              <os-arch>amd64</os-arch>

              <status>success</status>

            </metadata>

       

      What could be the issue? Please let me know if you have tried such workflows.

      Also let me know if you guys have tried in a different way to copy a file via BAO/TSO workflow.

       

      Thanks in advance,

      Yogeesh