5 Replies Latest reply on Feb 13, 2020 3:32 AM by Satish Potnuru

    Aruba CX Switches

    David Kipp
      Share This:

      Has anyone created a device adapter for HP Aruba CX series switches? We are starting to deploy some of the 8320s and the HP Procurve switch device adapter won't even login to them and it seems like have a device adapter specifically for the CX switches would be a better way to go.

        • 1. Re: Aruba CX Switches
          Yusuf Rampurawala

          There was a recent issue we had with ARUBA switches where it doesn’t login. That was resolved by changing sshPseudo tty to ansi. See if that helps.

           

           

          1 of 1 people found this helpful
          • 2. Re: Aruba CX Switches
            David Kipp

            Thank you for the suggestion Yusuf, unfortunately that had already been changed.

            • 3. Re: Aruba CX Switches
              David Kipp

              I went back this morning and looked at the transcript and it is actually logging in but for some reason is indicating login failed, here is the transcript:

              Transcript:

              View Details Login

               

              01/30/20 09:29:50 DEBUG: setting non debug spying buffer

              01/30/20 09:29:50 DEBUG: expecting prompt [Press any key to continue, you want to save current configuration, 3\. Command Line \(CLI\), 5\. Command Line \(CLI\), (>|#)], avoiding errors []

              Last login: Thu Jan 30 09:25:11 2020 from 10.10.10.100

               

               

               

               

              HPE-ARUBA-8320#

              01/30/20 09:29:52 DEBUG: matched prompt [(>|#)]

              01/30/20 09:29:52 DEBUG: sending slowly (stutterMillis:50ms) [

              ] at 1580394592075

              01/30/20 09:29:52 DEBUG: waiting default timeout of 60 seconds for response

              01/30/20 09:29:52 DEBUG: expecting response [(>|#)], avoiding errors []

               

               

              HPE-ARUBA-8320#

              01/30/20 09:29:52 DEBUG: matched response [(>|#)]

              01/30/20 09:29:52 DEBUG: expecting prompt [(?<!<Enter)>, ([Uu]ser.*:|[Ll]ogin.*:), [Pp]assword:, #], avoiding errors []

              01/30/20 09:29:52 DEBUG: matched prompt [#]

              01/30/20 09:29:52 DEBUG: sending slowly (stutterMillis:50ms) [no page

              ] at 1580394592153

              01/30/20 09:29:54 DEBUG: waiting default timeout of 60 seconds for response

              no page

              HPE-ARUBA-8320#

              01/30/20 09:29:54 DEBUG: matched response [#]

              View Details Login

               

              01/30/20 09:29:55 DEBUG: setting non debug spying buffer

              01/30/20 09:29:55 DEBUG: expecting prompt [Press any key to continue, you want to save current configuration, 3\. Command Line \(CLI\), 5\. Command Line \(CLI\), (>|#)], avoiding errors []

              Last login: Thu Jan 30 09:29:50 2020 from 10.10.10.100

               

               

               

               

              HPE-ARUBA-8320#

              01/30/20 09:29:57 DEBUG: matched prompt [(>|#)]

              01/30/20 09:29:57 DEBUG: sending slowly (stutterMillis:50ms) [

              ] at 1580394597247

              01/30/20 09:29:57 DEBUG: waiting default timeout of 60 seconds for response

              01/30/20 09:29:57 DEBUG: expecting response [(>|#)], avoiding errors []

               

               

              HPE-ARUBA-8320#

              01/30/20 09:29:57 DEBUG: matched response [(>|#)]

              01/30/20 09:29:57 DEBUG: expecting prompt [(?<!<Enter)>, ([Uu]ser.*:|[Ll]ogin.*:), [Pp]assword:, #], avoiding errors []

              01/30/20 09:29:57 DEBUG: matched prompt [#]

              01/30/20 09:29:57 DEBUG: sending slowly (stutterMillis:50ms) [no page

              ] at 1580394597325

              01/30/20 09:29:59 DEBUG: waiting default timeout of 60 seconds for response

              01/30/20 09:29:59 DEBUG: expecting response [#], avoiding errors []

              no page

              HPE-ARUBA-8320#

              01/30/20 09:29:59 DEBUG: matched response [#]

               

               

              It tries twice but fails with the error message: Cannot login to the device using any of the device security profiles.

              • 4. Re: Aruba CX Switches
                Meeta Lalwani

                Hello David,

                 

                If it is not resolved yet, I would recommend to log a support case and let one of the BMC expert to look into it.

                 

                Regards,

                Meeta

                • 5. Re: Aruba CX Switches
                  Satish Potnuru

                  Hello David,

                   

                  Is Issue resolved is resolved for you ?

                  I can see in this transcript that you can able to login in to the device and also executed "no page " command.

                  Little confused about the error you mentioned  (Cannot login to the device using any of the device security profiles.)

                  Kindly let me know If you still have any issue .