1 Reply Latest reply on Dec 27, 2019 7:21 AM by Peter Lundqvist

    Escalation causes ARERR 623

    Peter Lundqvist
      Share This:

      I don't understand what happens here.

       

      I have an escalation E1 that sets a display only filed on form F1.

       

      That display only field on from F1 triggers a filter push fields action on form F2.

       

      This push fileds action on form F2 sets another display only field on form F2

      In turn this triggers a set fields action on form F2 from form F3 (a vendor form).

       

      That whole sequence works just fine if I run the sequence manually by setting the display only field on Form F1 to something.

      However, if I run it through the escalation I get ARERR 623.

       

      At first I thought it was a permission error of some sort, but the user I use in midtier, and in developer studio both have the permissions required to modify all these fields.

      There seem to be no hints in the logs as to what goes wrong, but if I stop filtering by the thread executing the escalation I see that there is an API call (+VER) plus a query and update to the user_cache table (in another thread) just before the set fileds action throws the error.

       

      The users, in both cases, are members of the same group that is required for reading/updating that field.

      Any ideas on what to look for?