5 Replies Latest reply on Dec 9, 2019 2:05 PM by LJ LongWing

    Arabic Text sent via Webservice issue

    Kritika Prajapati
      Share This:

      As part of a functionality, Remedy is consuming third party webservice and sending them a Character field containing Arabic text, but the field value is appearing null at their end.

      Checked Webservice logs and found the field contains “?” marks instead of the actual Arabic text along with Request Number shared with them.

      Please have a look at below webservice logs highlighted in bold:

      <ns3:name>CHANNEL</ns3:name>

                  <ns3:value>BMC</ns3:value>

                  <ns3:description/>

                  <ns3:type/>

              </ns1:consumer>

              <ns1:provider>

                  <ns3:name/>

                  <ns3:value/>

                  <ns3:description/>

                  <ns3:type/>

              </ns1:provider>

              <ns1:additionalInformation>

                  <ns3:name/>

                  <ns3:value/>

                  <ns3:description/>

                  <ns3:type/>

              </ns1:additionalInformation>

          </ns0:header>

          <ns0:requestPayload>

              <ns4:messageCategory/>

              <ns4:language>100</ns4:language>

              <ns4:messageDetails>????? ?????? , ???? ?? ??? ????????? ???? ?????? ?? ??????? ???? ??????? ??? ???? ??? ?? ????? ?? ???? ??? ???? ?? ??? ???? ?? ??????? ???? ??? ??? ????? ?????? ????? ??????? REQ000000702575

      ???? ??</ns4:messageDetails>