6 Replies Latest reply on Jan 14, 2020 7:41 AM by Emmanuel Galia

    https://communities.bmc.com/docs/DOC-122501 gone?

    Thomas Miskiewicz
      Share This:

      We're trying to upgrade to ARS 19.08 on Linux and get that nice error

       

      LOG EVENT {Description=[Failed to executed Add Indexes on Columns BTable Server Utilitiy com.bmc.arsys.artools.ARToolsException: Unable to connect to source server]}

       

      I checked the Knowledge Base and found something https://communities.bmc.com/docs/DOC-122501 but it wouldn't open

       

      BTable.jpg

       

      BTable2.jpg

       

      Who can help?

        • 1. Re: https://communities.bmc.com/docs/DOC-122501 gone?
          rodrigo barcat

          Hi Thomas,

           

          I opened the cached page on google, I will paste below, but take care I think that BMC deleted this article and I do not know the reason

           

          SOLUTION:

           

           

           

          As Database Upgrade Utility Failed, review the 'upgradeutils.log' located under ..opt\bmc\ARSystem\db directory.

          The following error is displayed:
          ...........
          [WARN] [2019-09-05 19:16:08,718] Ignored XML validation warning
          org.xml.sax.SAXParseException: schema_reference.4: Failed to read schema document '
          http://www.springframework.org/schema/beans/spring-beans-3.0.xsd', because
          1) could not find the document;
          2) the document could not be read;
          3) the root element of the document is not <xsd:schema>.
          at
          com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:203)

          ...........


          The issue is with the 3rd party binary which Remedy installer is failing to read or locate.

          Perform the following steps to resolve this error and proceed with the Upgrade:
          1- Download the installer.
          2- Extract the zip file.
          3- Download zip file to the server from: ftp://ftp.bmc.com/pub/ARRecommendedFixes/Server/19.08/Installer%20fix%20for%20Spring-Beans/

          4- Go to 'ARSuiteKitLinux9.1.08.tar\ARSuiteKitLinux9.1.08\ARSuiteKit\Disk2\files' and Replace componentARServerLinux.zip with the one part of FixFile/componentARServerLinux.zip
          5- Give required permissions.
          6- Zip the file and run the the upgrade.

          2 of 2 people found this helpful
          • 2. Re: https://communities.bmc.com/docs/DOC-122501 gone?
            LJ LongWing

            I've looked internally and can't find that kb internally....sorry, can't find it.

            • 4. Re: https://communities.bmc.com/docs/DOC-122501 gone?
              Emmanuel Galia

              btw, we're encountering the same issue as well and was able to download the zipfile in the fix, and replaced the corresponding file under Disk2\files and re-tried the upgrade - still getting the error... anyone have this issue and was successful in fixing it?

              • 5. Re: https://communities.bmc.com/docs/DOC-122501 gone?
                Uwe Reimers

                bmc Installer BUG was fixed for me with the patch.

                1 of 1 people found this helpful
                • 6. Re: https://communities.bmc.com/docs/DOC-122501 gone?
                  Emmanuel Galia

                  Finally got our AR Server upgrade completed successfully:

                  - first and foremost, always do a backup prior to upgrade attempt, so if you get an issue you can restore back both DB and File system - yes, the "rollback" feature works but BMC tech support/engineering recommends a DB restore

                  - next, we replaced the zip file in the Disk2\files folder as directed from the article above

                  - then, we ran the installer in "pause" mode: ./setup.bin -Dbmc.install.PAUSE_MODE=true

                  - finally, after 1st pause, replaced 'activemq-osgi-5.15.9.jar' in the AR Server Install DIR/lib/upgradeutils folder (BMC provided the updated file)

                   

                  Think our issue was a combination of the 1st one documented in the article, wherein the installer is trying to access an external site to download files, which is fixed by the zip file replacement, and 2nd issue below:

                   

                  ---

                  Known defect which is fixed in 20.02 for which workaround has been provided. (changes in 'activemq-osgi-5.15.9.jar').
                  Defect SW00564097 - AR Upgrade Installation failed.

                   

                  While running upgrade utility we load all the jars in "lib/upgradeutils/" folder in random order (we provide './lib/upgradeutils/*' as classpath option in ardbutils.sh)

                  In upgradeutils folder there were total 96 jars present. Out of these 96 jars 10 jars are here which have spring.schemas file in its META-INF folder

                  So what happens, whenever this "activemq-osgi-5.15.10.jar" loaded before of "org.apache.servicemix.bundles.spring-beans-5.0.6.RELEASE_1.jar", proper entries of key-value pairs of these .xsd file locations are overridden and it works properly.
                  But if "activemq-osgi-5.15.10.jar" loaded after "org.apache.servicemix.bundles.spring-beans-5.0.6.RELEASE_1.jar", improper entries of key-value pairs of these .xsd file locations are overridden and it throws exception. (Root cause of failure in this issue)
                  Reference Exception : org.xml.sax.SAXParseException: schema_reference.4: Failed to read schema document 'http://www.springframework.org/schema/beans/spring-beans-3.0.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not .

                  Fix:
                  Load activemq-osgi-5.15.10.jar first explicitly in classpath. (eg : -cp './lib/upgradeutils/activemq-osgi-5.15.10.jar:./lib/upgradeutils/*')
                  Defect SW00563701

                  This will be fixed in ARS 20.02

                  ---

                   

                  Hope that helps some folks out there...

                   

                  And thanks again to the 1st rate BMC support team (esp. Max Gallegos) for the help in troublehooting our issue!!!

                  2 of 2 people found this helpful