1 Reply Latest reply on Sep 18, 2019 11:57 AM by Patrick Berrigan

    Anyone perform successful OSD operations on BMC version 12.8 Build 190124r?

    Patrick Berrigan
      Share This:

      I am running 12.8 build 190124r and having some trouble getting any kind of WIM image process to work. Here is a quick blurb about my environment. Our workstations are highly distrubuted across different VLANS and our BMC server is on our server VLAN. We utilize two Microsoft DHCP servers that are on the same server VLAN. I had to setup DHCP scope options 66 and 67 in order for the target workstation to PXE boot. On the workstation VLAN that my target machine is I have a Network Boot listener configured and within the workstation DHCP scope option 66 is the network boot listener name and 67 is bootx64.efi as we are UEFI only. The target machine PXE boots into a BMC shell and I can see my project name in the top right corner of the screen. The process begins by downloading (multicast protocol using unicast addressing)  and I can see temp directories being created on the local network boot listener, inside this directory are Windows update files some .net files, setup files, and other sub directories such as 1025, 1028, 1029 etc. This tells me the process is working however once it finishes with the download the target machine generates an error message of "Failed to get the file Windows/System32/osdhelper.config in wim file"

       

      Now I know some folks are going to say dont set the DHCP scope options, however if I dont do this the machine will not PXE boot. I have also looked at the Windows firewall and our AV McAfee solution and none of those are blocking BMC from what I can see. Ive tried setting DHCP scope option 66 to our BMC server name as well as the local network boot listener and the same error message occurs. I have also tried using a previous ADK version but the error remains. Currently using ADK Win10 1607 and we tried 1903 as well.

       

      In the BMC logs I can see the OSD process kick off with messages such as Queuing and Calling action OSDMulticastGiveServerInfo, Invooke local action and the action returned 0 as the code but the target workstation error remains.

       

      Now is multicasting required on the target subnet?