2 Replies Latest reply on Sep 17, 2019 2:51 PM by Abhay Bhagat

    Will closure policy on TSIM cell will be able to close the event in Blackout State

    Abhay Bhagat
      Share This:

      Dear Experts,

       

      I was trying to  close around 12k blackout events using a closure policy .

       

      What I made was

      Selector - Selecting Event Class (should apply on all events coming on TSIM cell)

      Policy :- Closure policy with condition to close old event with criteria Status == Blackout .

       

      But after this multiple alarms cames on cell but the BLACKOUT events never went to closed State .

       

      Please help me understand where my logic is wrong or does the cell does not function in this fashion on blacked out events and will never close the blacked out events .

       

      Regards,

      Abhay

        • 1. Re: Will closure policy on TSIM cell will be able to close the event in Blackout State
          Steve Mundy

          Hi Abhay,

           

          Closure policy does not work on events in blackout status. There is however a small change to get it working.

           

          In the cell kb\rules\im_internal.mrl file, locate the section for the rule im_internal_closure and change these lines:

           

              $POL.selector_ecf ($EV) where [ $EV.status != CLOSED AND $EV.status != BLACKOUT ]

              updates ALL $POL.closed_events ($CLOSE_EV) where [ $CLOSE_EV.status != CLOSED AND $CLOSE_EV.status != BLACKOUT ]

           

          to

           

              $POL.selector_ecf ($EV) where [ $EV.status != CLOSED ]

              updates ALL $POL.closed_events ($CLOSE_EV) where [ $CLOSE_EV.status != CLOSED ]

           

          then recompile the KB (mccomp -n <cell>) and restart the cell.

           

          regards, Steve

          • 2. Re: Will closure policy on TSIM cell will be able to close the event in Blackout State
            Abhay Bhagat

            Thanks Steve , I found the reason same as your comment and tried to update only cell config but after updating compiling , cell did not came up for 30+ min so  I reverted the config and then need   to restart TSIM twice and after around 2 hours everything went stable .

             

            Not sure was it config issue or some other issue with TSIM .

             

            Will try again sometime .

             

            Thanks for your response .

            Regards

            Abhay