6 Replies Latest reply on Aug 16, 2019 6:00 AM by Amol Kotwal

    MSA service does not get started

    Amol Kotwal
      Share This:

      Hello Experts,

       

      We have installed MSA 8.9.04.002 successfully. but msatomcat service does not get started automatically when tried manually also it throws below error.

       

      The msatomcat service terminated with the following service-specific error:

      Incorrect function.

       

       

      I have installed it on Windows Server 2016 Datacenter.

       

      Thanks & Regards,
      Amol Kotwal

        • 1. Re: MSA service does not get started
          Yusuf Rampurawala

          Hi Amol,

           

          Was there any changes made to the service?

          I see it in the image that it shows “msatomcat” and ideally by default it should be something like in the image below:

           

           

           

          Also check the even logs to see what specifically is causing the service to fail.

           

          Regards,

          Yusuf

          • 2. Re: MSA service does not get started
            Amol Kotwal

            Hi Yusuf,

             

            No change to service.

             

            We install with the default options as there is nothing to change except port.

             

            It does not have any error in logs. however below entry is what i suspect might be the cause.

             

            (Aug 14 2019 12:56:21.183 PM +0100),INFO,com.bmc.install.product.bcan.msa.server.MsaWebServerService,

              LOG EVENT {Description=[Command Line [D:\Program Files\BMC Software\BCA-Networks-MSA\tomcat\bin\tomcat9.exe //US//msatomcat --StdOutput D:\Program Files\BMC Software\BCA-Networks-MSA\data\log\tomcat_out.log --StdError D:\Program Files\BMC Software\BCA-Networks-MSA\data\log\tomcat_err.log] executed],Detail=[Results:['D:\Program' is not recognized as an internal or external command,

            operable program or batch file.

            ]]}

            (Aug 14 2019 12:56:21.183 PM +0100),INFO,com.bmc.install.product.bcan.msa.MsaPostInstallConfigUtilities,

              PROGRESS EVENT {Description=[postInstall.msa.description],Progress=[95],Detail=[postInstall.msa.startWebServer]}

            (Aug 14 2019 12:56:21.441 PM +0100),INFO,com.bmc.install.product.bcan.msa.server.MsaWebServerService,

              LOG EVENT {Description=[Starting web server service],Detail=[TIMEOUT

            SERVICE_NAME: msatomcat

                    TYPE               : 10  WIN32_OWN_PROCESS 

                    STATE              : 2  START_PENDING

                                            (NOT_STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)

                    WIN32_EXIT_CODE    : 0  (0x0)

                    SERVICE_EXIT_CODE  : 0  (0x0)

                    CHECKPOINT         : 0x0

                    WAIT_HINT          : 0x7d0

                    PID                : 4916

                    FLAGS              :]}

             

            Thanks & Regards,
            Amol Kotwal

            • 3. Re: MSA service does not get started
              Yusuf Rampurawala

              Yes, the error you pasted is what caused the service to be not created properly.

               

              And the reason you see this behaviour is because of  Windows 8.3 file names have been disabled. See below:

               

              Enabling Windows 8.3 file names

               

              To successfully install the application server and remote device agent, you must enable Microsoft Windows 8.3 file names before the installation. Perform the following steps to verify or enable Windows 8.3 file names:

              1.      Verify whether the Windows 8.3 file names feature is enabled: In a Windows command prompt enter fsutil behavior query disable8dot3.

              ·         If the output is disable8dot=0, then Windows 8.3 file names are enabled.

              ·         If the output is disable8dot=1, then Windows 8.3 file names are disabled. Continue with the next step to enable Windows 8.3 file names.

              2.      In a Windows command prompt, enable Windows 8.3 files names by entering fsutil behavior set disable8dot3 0 .

              3.      Restart Windows.

              1 of 1 people found this helpful
              • 4. Re: MSA service does not get started
                Amol Kotwal

                Hi Yusuf,

                 

                I'm not getting either of the options and if I try to set it 0 it doesn't work.

                 

                 

                Thanks & Regards,
                Amol Kotwal

                • 5. Re: MSA service does not get started
                  Yusuf Rampurawala

                  Looks like you are trying to install it on machine running Windows 10.

                  Please see the supported OS version list to see what all OS versions are supported.

                   

                  Regards,

                  Yusuf

                  1 of 1 people found this helpful
                  • 6. Re: MSA service does not get started
                    Amol Kotwal

                    Hi Yusuf,

                     

                    It is Windows Server 2016 Datacenter edition. would that be a problem?

                     

                    Thanks & Regards,
                    Amol Kotwal