1 Reply Latest reply on May 24, 2019 11:23 AM by Edison Santos

    Discovery - SWAP area desappeared

    Edison Santos
      Share This:

      Hi Guys!

       

      My Discovery SWAP area was disappeared. It is not displayed on ADMIN/DISK CONFIGURATION anymore and I don't know the reason why it was disappeared.

       

      I've tried to create a new swap area manually and on OS it seems to be OK (swapon --show), but, it still not appearing on Disk Configuration from UI/Admin.

       

      Can anyone give some help? What is the correct way to recreate SWAP area using a Discovery tool?

       

      Best regards,

      ES

        • 1. Re: Discovery - SWAP area desappeared
          Edison Santos

          Hi Guys!

           

          I still don't know why the SWAP area was disappeared, but I reconstructed it on disk /dev/sad2 with LINUX commands and it seems working fine now!

           

          The DEVICE was still there (fdisk-l) and I only needed to reconfigure it :

           

          Checking Disks:

           

          1. fdisk -l

            # Response:

              ............................ 

              /dev/sda2            /dev/sda2        1538048  18315263   8388608  82  Linux swap / Solaris

              ............................

            # it was showing "/dev/sda2"  as "Linux swap"

           

          2. swapon --show

              # response is empty

           

          3. dd if=/dev/zero of=/dev/sda2 bs=1024 count=8048576;

           

          4. mkswap /dev/sda2

           

          5. swapon /swapfile

           

          6. swapon --show

            # response is not empty anymore

           

          7. edit file: "/etc/fstab" and inserted line: "/dev/sda2 swap swap defaults 0 0"

           

          8. sudo swapon --show

            # reponse now is not empty anymore:

                NAME        TYPE        SIZE  USED  PRIO

                /dev/sda2  partition    8G      40K      -1

           

          Regards,

          ES