3 Replies Latest reply on May 16, 2019 12:33 PM by Barry Reilly

    TSA 89 SP4 Unified installer Fails at featureBSAOneClickInstall Stage

    Barry Reilly
      Share:|

      Hi

       

      Spent the last few days trying to build a PreProd test environment of the new TSA SP4 , before we apply it to our BSA 89 SP2 production environment.

       

      I'm getting no where, as despite , cleaning the slate and starting over with the same new server 2016, and sql 2016 SP2 database server.

       

       

      There is no OM-install.old generated as I believe its not getting to that stage.

       

      I opened a case and sent the bsainstallupgrade.log and confirmed that there is no om-install.log.

       

      At this point pulling one's hair out.

       

      The bsainstallupgrade.log for 8904 shows nothing other than an error occurred.

       

      Case :  [ ref:_00D30MODz._5001O1Uyf0n:ref ]

       

      I just sent an update to the case engineer to organise a webex tomorrow, but I'm not expecting a miracle

       

      Hoping someone else has experienced this.

       

      Things I have tried.

      • Uninstall if any BMC software from the Programs Installed List
      • Deleted the install path folders
      • Disabled UAC
      • Rebooted
      • Ran As Admin ( logged in as domain admin via domain group in local

       

       

       

       

       

       

       

        • 1. Re: TSA 89 SP4 Unified installer Fails at featureBSAOneClickInstall Stage
          Barry Reilly

          On a side note if I use the non unified installer method it moves on and does create a om-install.log.

           

          But its the principle of it and I deleted that silent install method attempt to go back to using the unified method, so we can get to the bottom of this weird issue.

          • 2. Re: TSA 89 SP4 Unified installer Fails at featureBSAOneClickInstall Stage
            Bill Robinson

            i looks like the problem is the install is failing:

              LOG EVENT {Description=[Executing Install command:],Detail=[[E:\Software\TSASP4\App Server\TSSA89-SP4-WIN64\Disk1\files\installers\appserver_64\TSSA89-SP4-WIN64.exe, -s, -f1E:\Software\TSASP4\App Server\TSSA89-SP4-WIN64\Disk1\files\installers\appserver_64\response_file_working.properties]]}

            (May 16 2019 03:25:17.542 PM +0100),INFO,com.bmc.install.product.bladelogic.fresh.BladelogicFreshInstallProgressManager$ProgressLogger,

              PROGRESS EVENT {Description=[TrueSight Server Automation (29%)],Progress=[29],Detail=[Installing Application Server (Remaining time - 39 mins 0 secs)]}

            [...]

            (May 16 2019 03:26:07.527 PM +0100),SEVERE,com.bmc.install.product.bladelogic.fresh.BladelogicFreshInstallManager,

              THROWABLE EVENT {Description=[A component installation has failed.],Detail=[Command execution returned a non-zero code (-2147213312): ]},

             

            some googling shows that the exit code for installshield (the appserver installer) means there's an issue w/ the space in the path.  can you put an underscore or dash or get rid of the space in 'App Server' ?

            1 of 1 people found this helpful
            • 3. Re: TSA 89 SP4 Unified installer Fails at featureBSAOneClickInstall Stage
              Barry Reilly

              That is just.... wow.... and then I remembered a similar issue last April when I did SP2 in-place upgrade.

               

              Thanks Bill