2 Replies Latest reply on Jun 26, 2019 4:25 AM by Peter Lundqvist

    EXPQRY in AIF form is empty in request console

    Peter Lundqvist
      Share This:

      We have a weird issue in our 9.1.03.001 production system (not in test).

      A drop down list connected query menu works if you access the form by itself, but if it is opened from Request Entry it is empty.

      Looking at the logs make it very obvious what the issue is:

       

      Requester Console:

      /* ti apr 23 2019 21:30:30.2020 */ SELECT DISTINCT T3863.C536870914, T3863.C536870913 FROM T3863 WHERE ((T3863.C536870914 IS NOT NULL) AND (T3863.C536870913 IS NOT NULL) AND ROWNUM <= 0 ) ORDER BY T3863.C536870914 ASC, T3863.C536870913 ASC

       

      Direct access to form:

      /* ti apr 23 2019 21:42:49.0950 */ SELECT DISTINCT T3863.C536870914, T3863.C536870913 FROM T3863 WHERE ((T3863.C536870914 IS NOT NULL) AND (T3863.C536870913 IS NOT NULL)) ORDER BY T3863.C536870914 ASC, T3863.C536870913 ASC

       

      At the end of the WHERE clause this clause exists: AND ROWNUM <= 0

      That will obviously return 0 rows (or less ).

      The menus are the same. There is nothing else related in the logs but this is what they say when accessesing from Request Entry:

      <CLAT> /* Tue Apr 23 2019 21:30:25.898 */-API call, Procedure #7

      (ARNOTE 8914)

                Beställning utförd av: (536870927) = ******

                Company(536870926) = Lantmäteriet

                Person ID(536870937) = PPL000000002454

                Last Name*+(1000000018) = ***********

                First Name*(1000000019) = *****

      ActiveLink End:- LM:FRskrivare:Set_User | LM:FRskrivare_Bestall/Default Administrator View - Tue Apr 23 2019 21:30:25 ms 971

      EVENT End:- Window Open |   | LM:FRskrivare_Bestall/Default Administrator View   Tue Apr 23 2019 21:30:25

             /* ti apr 23 2019 21:30:30.1970 */ +EXPQRY  ARExpandQueryMenu --  from Mid-tier (protocol 24) at IP address 143.237.89.240 using RPC // :q:0.0s  - cacheId : 1094, AuthGuid : NULL

             /* ti apr 23 2019 21:30:30.2010 */ Generating prepared statement

             /* ti apr 23 2019 21:30:30.2010 */ OK

             /* ti apr 23 2019 21:30:30.2020 */ Binding [0] parameters to prepared statement

             /* ti apr 23 2019 21:30:30.2020 */ OK

             /* ti apr 23 2019 21:30:30.2020 */ SELECT DISTINCT T3863.C536870914, T3863.C536870913 FROM T3863 WHERE ((T3863.C536870914 IS NOT NULL) AND (T3863.C536870913 IS NOT NULL) AND ROWNUM <= 0 ) ORDER BY T3863.C536870914 ASC, T3863.C536870913 ASC

             /* ti apr 23 2019 21:30:30.2020 */ OK

             /* ti apr 23 2019 21:30:30.2030 */ -EXPQRY           OK

      (ARNOTE 8914)

       

      I've seen similar things when FTS was glitching, but there is no FTS activity here.

      I've seen similar things when operating-mode was not 0, but this is not the case here either.

      Any ideas?