7 Replies Latest reply on Mar 20, 2019 5:54 AM by Andreas Mitterdorfer

    Cannot build a Service Target as it is stuck in "Build in Progress

    Loaone Seleka
      Share:|

      Good Day,

       

      May you please assist as i am trying to build service targets but they are stuck in "Build in Progress". I have enabled the logs the SLM preferences and i see the below error. I have attached the log file as well.

       

      11:26:24 18 Mar 2019 SLM BRIE Could not update build status in slmbrsvc-SetBuildInfo() using ARSetEntry for rule: SLM00201_MeasReqAssoc.  AR Error 2

      11:26:24 18 Mar 2019 SLM BRIE Status' messageNum = 9008

       

      11:26:24 18 Mar 2019 SLM BRIE Status' messageText = The size of the memory buffer used in XDR (external data representation) is invalid.

       

      11:26:24 18 Mar 2019 SLM BRIE Status' AppendText = (null)

       

       

       

      I have checked the below KA and i see that patch might be released but i want some kind of confirmation

       

      Service Targets stay in 'Build in Progress"

      Service Targets stuck in "Build in Progress"

       

      Regards,

      Loaone

        • 1. Re: Cannot build a Service Target as it is stuck in "Build in Progress
          Andreas Mitterdorfer

          Can you try to rebuild the datasource filters and then check SVT build again?

          • 2. Re: Cannot build a Service Target as it is stuck in "Build in Progress
            Loaone Seleka

            Hi Andreas,

             

            May you guide me on how do i do that please?

             

            Regards,

            Loaone

            • 4. Re: Cannot build a Service Target as it is stuck in "Build in Progress
              Loaone Seleka

              Good Day

               

              I tried re-building but some are still stuck in “Build In Progress”. I have attached log files as well.

               

               

               

              Regards,

              Loaone

              • 5. Re: Cannot build a Service Target as it is stuck in "Build in Progress
                Andreas Mitterdorfer

                I checked the logs but can't find an indication that the datasource filters were rebuild (eg. zSLMGen:HPD:Help Desk_MeasReqAvailResetReqID`!).

                I only found CF calls for zSLMGen:SLM00203_MeasReqAssoc`! filter.

                 

                Can you press View for one of the datasource filters which are build in progress. In the dialog there is a field called "build messages" which ideally contains information, why the build failed. Can you post the content?

                • 6. Re: Cannot build a Service Target as it is stuck in "Build in Progress
                  Loaone Seleka

                  Good Day

                   

                  Please find the build message for HPD:Help Desk_MeasReqAvailResetReqID below. I have also attached the screen shot as well.

                   

                  09:48:11 18 Mar 2019

                  09:48:11 18 Mar 2019  ***************************************************************************

                  09:48:11 18 Mar 2019  Start Create-Rule Processing ...

                  09:48:11 18 Mar 2019  Command: "Create-Rule"; form "SLM:RuleDefinition"; guid: "AGGAAEHXHSDG4APO9XN8PNMPAY2L54"; EntryIdString "000000000000673"

                  09:48:12 18 Mar 2019  Looking up events, conds & actions for rule "HPD:Help Desk_MeasReqAvailResetReqID"

                  09:48:14 18 Mar 2019

                  09:48:14 18 Mar 2019  Interpreting Rule: HPD:Help Desk_MeasReqAvailResetReqID

                  09:48:14 18 Mar 2019  Building filters on form: HPD:Help Desk

                  09:48:14 18 Mar 2019  Event Guid is AGGAAEHXHSDG4APO9XN7PNMPAX2L5G

                  09:48:14 18 Mar 2019  Condition Guid is: AGGAAEHXHSDG4APO9XN8PNMPAX2L50

                  09:48:14 18 Mar 2019  Action Guid is AGGAAEHXHSDG4APO9XN8PNMPAY2L52

                  09:48:14 18 Mar 2019  Execution order for rule :  0

                  09:48:14 18 Mar 2019

                  09:48:14 18 Mar 2019  Event Processing ...

                  09:48:16 18 Mar 2019  Completed processing Data Event (ProcessDataEvent) :  HPD:Help Desk_DE_None

                  09:48:16 18 Mar 2019

                  09:48:16 18 Mar 2019  Condition Processing ...

                  09:48:16 18 Mar 2019  Processing Condition :  HPD:Help Desk_None.

                  09:48:16 18 Mar 2019  Completed processing condition  :  HPD:Help Desk_None

                  09:48:16 18 Mar 2019  returning 0

                  09:48:16 18 Mar 2019  Condition :

                  09:48:16 18 Mar 2019

                  09:48:16 18 Mar 2019  Action Processing ...

                  09:48:17 18 Mar 2019  SrcObj: ; RefObj:SL001143D417CBsXFOQwuS6MAgFscA ; DestObj:

                  09:48:18 18 Mar 2019  Processing Set Fields Action :  HPD:Help Desk_MeasReqAvailResetReqID_SVA.

                  09:48:18 18 Mar 2019  Completed processing Set values Action :  HPD:Help Desk_MeasReqAvailResetReqID_SVA.

                  09:48:18 18 Mar 2019

                  09:48:18 18 Mar 2019  Generating AR Workflow ...

                  09:48:19 18 Mar 2019  Workflow::Delete - Delete using Name in SLM:RuleDefinition

                  09:48:19 18 Mar 2019

                  09:48:19 18 Mar 2019  ruleName: HPD:Help Desk_MeasReqAvailResetReqID

                  09:48:19 18 Mar 2019  Workflow::DeleteRuleFilRegAndFilAssocAndWorkflow - Delete entries with qualification = "'490003300' LIKE "%HPD:Help Desk_MeasReqAvailResetReqID%""

                  09:48:20 18 Mar 2019  Workflow::DeleteRuleFilRegAndFilAssocAndWorkflow - No Entries found to delete from SLM:RuleFilterRegistration form

                  09:48:20 18 Mar 2019  Start generating AR Workflow...

                  09:48:20 18 Mar 2019  Workflow::DoDataEvents - Processed Data Event (DoDataEvents)): HPD:Help Desk_DE_None

                  09:48:20 18 Mar 2019  Workflow::UpdateWorkflowActions - Processing AR Set Fields Action

                  09:48:20 18 Mar 2019  Workflow::UpdateWorkflowActions - Processed AR Set fields action

                  09:48:20 18 Mar 2019  Begin Create WorkFlow Action.

                  09:48:20 18 Mar 2019  End Create WorkFlow Action.

                  09:48:20 18 Mar 2019  Creating filters on form: HPD:Help Desk

                  09:48:20 18 Mar 2019  Begin Create WorkFlow Action.

                  09:48:21 18 Mar 2019  Success on OMRelObjWFAct::checkOverlaySchema - ARGetSchema API - HPD:Help Desk

                  09:48:21 18 Mar 2019  Value of smoprop PROPERTY IS FOUND

                  09:48:21 18 Mar 2019  Value of smoprop PROPERTY IS 2

                  09:48:21 18 Mar 2019  Successfully creating filter - "zSLMGen:HPD:Help Desk_MeasReqAvailResetReqID`!"

                  09:48:21 18 Mar 2019  Before EscalationCreate

                  09:48:21 18 Mar 2019  End Create WorkFlow Action.

                  09:48:21 18 Mar 2019  Workflow::Update - Completed creating Filters !

                  09:48:21 18 Mar 2019  Rule Interpretation Successful !

                   

                   

                  Regards,

                  Loaone

                  • 7. Re: Cannot build a Service Target as it is stuck in "Build in Progress
                    Andreas Mitterdorfer

                    Hi Loaone,

                    It's strange that the build status is still "build in progress" though the filter was created successfully.

                     

                    Can you open SLM:RuleDefintion and search for "HPD:Help Desk_MeasReqAvailResetReqID" in name field and then try to set the build status to "Build Successfully" manually & Save to check wheter this is working?

                    Can you do the same with rule SLM00203_MeasReqAssoc ?

                    If saving is working:

                    Please can you check, wheter slmbrsvc.exe is started with the --unicode string in armonitor.conf?

                     

                    Can you create a client side api logging (ARAPILOGGING=27) for slmbrsvc process when you build the SVT?

                     

                    I also suggest to open a ticket with BMC for further in case you haven't done that already, they probably are able to help faster.

                     

                    BR,

                    Andreas