8 Replies Latest reply on Apr 2, 2019 7:02 PM by Carl Wilson

    RSSO redirection issue

    Guruprasad Balachandra
      Share:|

      18.08

      Description of the issue: Installed RSSO on the same box as AR Server and Mid Tier.

      installed RSSO integration with AR server

      Installed RSSO integration with Mid tier.

      Configured RSSO to use AR authentication with default Realm (*)

       

      when i type in the mid tier url, it redirects to RSSO page. which is fine. i type in user id/pwd, it dispays the RSSO login screen again.

      logged into RSSO Admin console. i can see the session getting created successfully

       

      Any config to check ?

        • 1. Re: RSSO redirection issue
          Arun Koul

          Can you check the URLs configured in rsso-agent.properties file?

           

          It should be as follows-

          sso-external-url=<MT hostname or external URL>/rsso

          sso-service-url=<MT hostname>/rsso

          1 of 1 people found this helpful
          • 3. Re: RSSO redirection issue
            Arun Koul

            Just check the exact hostname of the MT and its port.

            Your issue will be resolved.

            2 of 2 people found this helpful
            • 4. Re: RSSO redirection issue
              Carl Wilson

              Hi Guru,

              it needs to be the FQDN in RSSO, you cannot use short names as the cookie is tied to the domains and the redirection is checked on the domain contained in the URL against the cookie defined in RSSO.

              So, check that you are using the FQDN for server names in all of the RSSO configurations.

               

              Cheers

              Carl

              4 of 4 people found this helpful
              • 5. Re: RSSO redirection issue
                Guruprasad Balachandra

                Thanks Arun for suggestions..matching the cookie domain in all configuration fixed the issue..

                • 6. Re: RSSO redirection issue
                  Guruprasad Balachandra

                  It was indeed Carl and few setting in config wasn't correct. I thought for a second I need to set up domain. But didn't need it. All sorted now.

                  • 7. Re: RSSO redirection issue
                    Guruprasad Balachandra

                    Hi Arun, setting up RSSO for MyIT now. the Tomcat loads and then stop. i had put the logging into debug mode. it seems to show the hostname: ITSM1808. against the Tenant in DataStore. not sure to change it to ITSM1808.local

                     

                    could that be the issue ?

                     

                    16:51:17.349 | Notification poller            | RID: none | OpId: none | DEBUG   | c.b.b.m.i.Application | replying with value=com.bmc.bsm.mobile.vo.profile.MobilityARUser@fe024e8[user=Remedy Application Service,mobilityAPIVersion=1,applicationName=MyIT-ITSM,applicationVersion=1.0,deviceModel=iPhone Simulator,tenantId=000000000000001,storeId=000000000000001_,poolPosition=0,adminPoolPosition=0,isInUse=true,providerSourceName=<null>,impersonatedBy=<null>]

                    16:51:17.349 | Notification poller            | RID: none | OpId: none | DEBUG   | c.b.b.m.i.Application | Found MobilityUser in request/session is 'com.bmc.bsm.mobile.vo.profile.MobilityARUser@fe024e8[user=Remedy Application Service,mobilityAPIVersion=1,applicationName=MyIT-ITSM,applicationVersion=1.0,deviceModel=iPhone Simulator,tenantId=000000000000001,storeId=000000000000001_,poolPosition=0,adminPoolPosition=0,isInUse=true,providerSourceName=<null>,impersonatedBy=<null>]'.

                    16:51:17.350 | Notification poller            | RID: none | OpId: none | DEBUG   | c.b.b.m.service.SecurityService | Creating admin user for data store DataStore [id=000000000000001_2, hostname=ITSM1808, port=0, type=ARServer, tenantId=000000000000001]...

                    16:51:17.375 | Notification poller            | RID: none | OpId: none | DEBUG   | c.b.b.m.i.Application | replying with value=com.bmc.bsm.mobile.vo.profile.MobilityARUserPoolImpl@27018e3e

                    16:51:17.375 | Notification poller            | RID: none | OpId: none | DEBUG   | c.b.b.m.i.Application | Can't find request attribute myit.arserveruser.MyIT-ITSM.srm.admin from thread local

                    16:51:17.375 | Notification poller            | RID: none | OpId: none | DEBUG   | c.b.b.m.i.Application | replying with request value=null

                    16:51:17.375 | Notification poller            | RID: none | OpId: none | DEBUG   | c.b.b.m.i.Application | Start to set request attribute myit.arserveruser.MyIT-ITSM.srm.admin

                    16:51:17.375 | Notification poller            | RID: none | OpId: none | DEBUG   | c.b.b.m.i.Application | Start to set request attribute myit.arserveruser.MyIT-ITSM.srm.admin for current thread

                    16:51:17.396 | Notification poller            | RID: none | OpId: none | DEBUG   | c.b.b.m.i.Application | replying with value=com.bmc.bsm.mobile.vo.profile.MobilityARUserPoolImpl@27018e3e

                    16:51:17.983 | ification thread in QUEUE mode | RID: none | OpId: none | ERROR   | c.b.b.m.s.p.a.APNSNotificationProgressListener | Critical exception in notification thread '3'!

                    16:51:17.983 | ification thread in QUEUE mode | RID: none | OpId: none | ERROR   | c.b.b.m.s.p.a.APNSNotificationProgressListener | Critical exception in notification thread '1'!

                    16:51:17.985 | ification thread in QUEUE mode | RID: none | OpId: none | ERROR   | c.b.b.m.s.p.a.APNSNotificationProgressListener | Exception is:

                    javapns.communication.exceptions.CommunicationException: Communication exception: java.net.ConnectException: Connection refused: connect

                    at javapns.communication.ConnectionToAppleServer.getSSLSocket(ConnectionToAppleServer.java:158)

                    at javapns.notification.PushNotificationManager.initializeConnection(PushNotificationManager.java:106)

                    at javapns.notification.transmission.NotificationThread.runQueue(NotificationThread.java:257)

                    at javapns.notification.transmission.NotificationThread.run(NotificationThread.java:202)

                    at java.lang.Thread.run(Unknown Source)

                    Caused by: java.net.ConnectException: Connection refused: connect

                    at java.net.DualStackPlainSocketImpl.connect0(Native Method)

                    at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)

                    at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)

                    at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)

                    at java.net.AbstractPlainSocketImpl.connect(Unknown Source)

                    at java.net.PlainSocketImpl.connect(Unknown Source)

                    at java.net.SocksSocketImpl.connect(Unknown Source)

                    at java.net.Socket.connect(Unknown Source)

                    at sun.security.ssl.SSLSocketImpl.connect(Unknown Source)

                    at sun.security.ssl.SSLSocketImpl.<init>(Unknown Source)

                    at sun.security.ssl.SSLSocketFactoryImpl.createSocket(Unknown Source)

                    at javapns.communication.ConnectionToAppleServer.getSSLSocket(ConnectionToAppleServer.java:155)

                    ... 4 common frames omitted

                    16:51:17.985 | ification thread in QUEUE mode | RID: none | OpId: none | DEBUG   | c.b.b.m.s.p.a.APNSNotificationProgressListener | Successfully pushed notifications: []

                    16:51:17.985 | ification thread in QUEUE mode | RID: none | OpId: none | DEBUG   | c.b.b.m.s.p.a.APNSNotificationProgressListener | Notifications failed to push: []

                    16:51:17.985 | ification thread in QUEUE mode | RID: none | OpId: none | DEBUG   | c.b.b.m.s.p.a.APNSNotificationProgressListener | Notification thread '1' finished.

                    16:51:17.985 | ification thread in QUEUE mode | RID: none | OpId: none | ERROR   | c.b.b.m.s.p.a.APNSNotificationProgressListener | Exception is:

                    javapns.communication.exceptions.CommunicationException: Communication exception: java.net.ConnectException: Connection refused: connect

                    at javapns.communication.ConnectionToAppleServer.getSSLSocket(ConnectionToAppleServer.java:158)

                    at javapns.notification.PushNotificationManager.initializeConnection(PushNotificationManager.java:106)

                    at javapns.notification.transmission.NotificationThread.runQueue(NotificationThread.java:257)

                    at javapns.notification.transmission.NotificationThread.run(NotificationThread.java:202)

                    at java.lang.Thread.run(Unknown Source)

                    Caused by: java.net.ConnectException: Connection refused: connect

                    at java.net.DualStackPlainSocketImpl.connect0(Native Method)

                    at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)

                    at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)

                    at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)

                    at java.net.AbstractPlainSocketImpl.connect(Unknown Source)

                    at java.net.PlainSocketImpl.connect(Unknown Source)

                    at java.net.SocksSocketImpl.connect(Unknown Source)

                    at java.net.Socket.connect(Unknown Source)

                    at sun.security.ssl.SSLSocketImpl.connect(Unknown Source)

                    at sun.security.ssl.SSLSocketImpl.<init>(Unknown Source)

                    at sun.security.ssl.SSLSocketFactoryImpl.createSocket(Unknown Source)

                    at javapns.communication.ConnectionToAppleServer.getSSLSocket(ConnectionToAppleServer.java:155)

                    • 8. Re: RSSO redirection issue
                      Carl Wilson

                      Hi Guru,

                      Does it load correctly when you do not have it integrated with RSSO?

                      Have you integrated DWP Catalog also in this environment?

                       

                      The errors you posted are to do with the Apple IOS integration, so these can be ignored if not using it.

                       

                      Cheers

                      Carl

                      1 of 1 people found this helpful