5 Replies Latest reply on Mar 15, 2019 5:11 AM by Arif Alibay

    Patrol Agent 11.3.01 for Linux installation problem

    victor chan
      Share:|

      Hi All,

       

      I try to install the latest version Patrol Agent 11.3.01 on my test environment platform SuSE Linux Enterprise 12 SP4.

      But it got failure when I open the browser to call the installation page.

      I'm using attend installation, first, extract package and start running the installer on the Linux.

      When I open the browser, access the URL given by installer, then installer just got failure and return a error code as following:

      ============================================================================================================

      ------------------------------------------------------------------------------

        The WEB server has successfully started.

        To begin uninstallation, open a browser and connect to the following URL:

        http://xxx.xxx.xxx.xxx:50001/

      ------------------------------------------------------------------------------

       

        When you are finished with the uninstallation,

        or if you want to shut down the uninstallation,

        press the enter key to exit this program.

       

      -> /home/user/BMCINSTALL/setup1_031419171845.sh: line 1226: read: read error: 0: Resource temporarily unavailable

       

      Exiting ... please wait!

       

       

      /home/user/BMCINSTALL/setup1_031419171845.sh: line 325: 16203 Terminated              $PERL $BMC_INSTALL_TEMP/setup.plx $UNINSTALL  (wd: ~/BMCINSTALL/linux-15922-190314091845)

      user@linux:/opt/bmc/Uninstall>

      ============================================================================================================

       

      Anyone know what's problem cause this issue?

      I had tried many time install and reboot the machine still not OK, please help.

        • 1. Re: Patrol Agent 11.3.01 for Linux installation problem
          Arif Alibay

          It could be that the current shell has some limit in the number of  files open  or number of processes

          Please check the value of  ulimit -n.

          or increase the value by typing for ie

          ulimit -n 20480, then run the setup again

           

          if this still doesn't help, please send us the output of

          ulimit -a

          Thanks,

          Arif

          • 2. Re: Patrol Agent 11.3.01 for Linux installation problem
            Michael Ashall

            I would check the installation log as this might help also.

             

            If the agent is crashing then

            This may happen if the PATROL Agent is falling short of resources on the server. Please modify the following values in /etc/security/limits file.  -1 implies there are no limits:

            Patrol User :

            rss = -1
            stack = -1
            data = -1

            -> Once you apply the changes, please check the ulimit output. 

            # ulimit -Ha
            time(seconds) unlimited
            file(blocks) 2097151
            data(kbytes) unlimited
            stack(kbytes) unlimited
            memory(kbytes) unlimited
            coredump(blocks) unlimited
            nofiles(descriptors) unlimited


            I don't think you are getting that far?

            • 3. Re: Patrol Agent 11.3.01 for Linux installation problem
              victor chan

              I had changed the open files number to 20480, but still not work.

              This is my ulimit -a result:

              #ulimit -a

              core file size          (blocks, -c) unlimited

              data seg size           (kbytes, -d) unlimited

              scheduling priority             (-e) 0

              file size               (blocks, -f) unlimited

              pending signals                 (-i) 3763

              max locked memory       (kbytes, -l) 64

              max memory size         (kbytes, -m) unlimited

              open files                      (-n) 20480

              pipe size            (512 bytes, -p) 8

              POSIX message queues     (bytes, -q) 819200

              real-time priority              (-r) 0

              stack size              (kbytes, -s) 8192

              cpu time               (seconds, -t) unlimited

              max user processes              (-u) 3763

              virtual memory          (kbytes, -v) unlimited

              file locks                      (-x) unlimited

               

              And I had found a silent install is no problem, it only failure on attend installation.

              • 4. Re: Patrol Agent 11.3.01 for Linux installation problem
                Razeem Mohamed

                If silent install works, make sure the same options used in silent install are fed. That might help.

                • 5. Re: Patrol Agent 11.3.01 for Linux installation problem
                  Arif Alibay

                  somehow  read command fails to get the correct  data from stdin (web browser)

                  if you check read command at line 1226 , you will have something as

                   

                  if [ "$BROWSER" -eq 0 ] ; then

                        $CLEAR

                        echo ""

                        echo $BORDER

                        asciitext 13 $url

                        echo $BORDER

                        echo ""

                        asciitext 14

                        echo ""

                        echo $N "-> $C"

                        read ACK

                     fi

                   

                  So read here receives some data from the browser which makes the sh  to fail with the message read error: 0: Resource temporarily unavailable

                   

                  It could be related to your browser, what type of browser are you using ?

                  you may also try to run the install in trace mode

                  ./setup.sh -serveronly -timeout 300 -trace

                  trace files will be located on a folder hostname-**** under /home/user/BMCINSTALL/