1 Reply Latest reply on Mar 14, 2019 7:28 AM by Andreas Mitterdorfer

    SmartIT 19.02 upgrade: Context [/smartit] startup failed due to previous errors

    Andreas Mitterdorfer
      Share This:

      I upgraded one of my testboxes from 18.08 to 19.02 and after smartit upgrade, tomcat 8.5 fails to load the smartit context.

      Note: I have DWP & SmartIT deployed in same tomcat, DWP runs fine.  For troubleshooting i removed DWP context from loading.

       

      catalina.out shows:

      13-Mar-2019 08:39:58.082 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.startInternal One or more Filters failed to start. Full details will be found in the appropriate container log file

      13-Mar-2019 08:39:58.082 SEVERE [localhost-startStop-1] org.apache.catalina.core.StandardContext.startInternal Context [/smartit] startup failed due to previous errors

       

      smartit.log shows:

      13/Mar/2019:08:39:57 c.b.b.m.i.MyItContextListener  Context initialization...

      13/Mar/2019:08:39:58 c.b.b.myit.filter.ExpiresFilter  Filter initialized with configuration ExpiresFilter[active=true, forceOverride=true, excludedResponseStatusCode=[304], default=ExpiresConfiguration[startingPoint=ACCESS_TIME, duration=[0 SECOND]], byType={text/html=ExpiresConfiguration[startingPoint=ACCESS_TIME, duration=[1 SECOND]], image=ExpiresConfiguration[startingPoint=ACCESS_TIME, duration=[7 DAY]], application/json=ExpiresConfiguration[startingPoint=ACCESS_TIME, duration=[0 SECOND]]}]

      13/Mar/2019:08:39:58 c.b.b.m.f.AuthenticationFilter  Initializing Authentication Filter

      13/Mar/2019:08:39:58 c.b.b.m.filter.SSODecisionFilter  Decision filter initiated

      13/Mar/2019:08:39:58 c.b.b.m.filter.SSODecisionFilter  Decision filter shut down

      13/Mar/2019:08:39:58 c.b.b.m.i.MobilityServerContextListener  Deregistered the current mobility server from cluster vie-vm-266.

      13/Mar/2019:08:39:58 c.b.b.m.i.MobilityServerContextListener  BMC Mobility Server shutdown

       

      Logs are attached.

       

      I found If Smart IT and DWP are on the SAME server Smart IT 18.08, Smart IT stops working after upgrading DWP to 19.02  which seems similar (haven't found the java.lang.NoClassDefFoundError: io/jsonwebtoken/ExpiredJwtException in logs though), but the solution to replace the rsso .jar files (tried with 18.08 versions and 19.02 versions) did not solve the issue.

       

      I tried to disable the SSODecisionFilter in web.xml but still the context failed to deploy.

      I assume the problem is the Authentication Filter however I do not have any idea how to continue troubleshooting.

      Anyone experienced the same or has an idea how to troubleshoot the problem with filter in more detail?

       

      Thanks in advance!