4 Replies Latest reply on Jan 17, 2019 12:36 PM by Rob Farrington

    First Name/Last Name email tags not showing

    Rob Farrington
      Share This:

      Hey all,

       

      I'm having an issue where the First Name and Last Name email tags are not showing up in the emails sent to users or assignees. It is either showing up as the actual variable, i.e. [FIRST_NAME_2] or blank.

       

      I've put in a support ticket (still waiting), and searched the database and haven't seen an answer yet. Anyone have experience with this happening before?

       

      Thank you all!

        • 1. Re: First Name/Last Name email tags not showing
          Nicolas Roome

          If it's showing the variable, it's because you don't have the right variable. Did you click and drag it from the list?

           

          If it is not showing the value, and is blank/null instead, two things to check:

           

          1) Make sure the value is set before the rule runs (ie: if you have a business rule that sets the value, and a business rule that sends the notification, make sure the former rule runs before the latter, by adjusting rule order)

           

          2) Make sure the recipient has permission to the field. So if the recipient address matches a user, make sure that user's container record has permission to the field (at least 'view'). If the recipient address does not match a user, then make sure the 'Portal Guest' role for that container has permission to the field.

          • 2. Re: First Name/Last Name email tags not showing
            Rob Farrington

            I am using the correct variable, listed in the system as follows:

             

            Incident: [FIRST_NAME_2]

            Service Request : [FIRST_NAME_1]

             

            As far as the business rules, there is only one running per "step", such as assigned, resolved, or created/closed. There are no competing rules for email at the same time.

             

            Permissions are at the Admin level at this time, with populated fields in the ticket before submission of the update.

            • 3. Re: First Name/Last Name email tags not showing
              Vern Meyer

              Check your "GUEST" account's permissions to those fields. From what I remember, that guest account is used to send emails, so it needs access to the field variables.

              • 4. Re: First Name/Last Name email tags not showing
                Rob Farrington

                DING!! That was it. The Portal Guest account for the Workspace was set to NO for the First Name and Last Name fields. Very good to know for all of my workspaces.

                 

                Thanks Vern Meyer and Nicolas Roome for the help!

                 

                Rob Farrington