2 Replies Latest reply on Dec 14, 2018 10:50 AM by Phil Grainger

    ReOrg Plus : Long running ReOrg job BMC50780I

    Anoop PV
      Share:|

      Hi,

       

      We have a long running job due to the excessive logs for BMC50780I. The table is highly utilized during the ReOrg phase. Any easier way to bypass the logs for BMC50780I ?

       

      The ReOrg does deletes older records by having a where clause as TIME < CURRENT TIMESTAMP   . Is this the reason ? any benefits if we change to DATE < CURRENT DATE - 1 DAYS

       

      Thanks,

      Anoop

        • 2. Re: ReOrg Plus : Long running ReOrg job BMC50780I
          Phil Grainger

          Hi Anoop

           

          You might also want to log a call with support - they will be able to help you out. But in the meantime, here are some suggestions you could try

           

          Looks like you may be using the default of LONGLOG CONTINUE:

           

          You could specify LONGLOG DRAIN which would cause Reorg Plus to immediately DRAIN the object and go into LOGFINAL and SWITCH.  This may be a problem if the rapidly arriving log records represent processes that will prevent a DRAIN from occurring.  And if LONGLOG is detected it means there are a lot of log records to apply, so LOGFINAL and SWITCH may take some time relatively speaking.  It should still complete in a matter of seconds, just longer than if there is a point where log record arrive slows down.

           

          You may also be allowing DELAY to default:

           

          Unless you have changed the default, it will be 300 seconds, which means Reorg Plus will wait five minutes and re-check for a LONGLOG condition.  It might help if you lower this DELAY specification to 120 (two minutes) or even 60 (one minute) to get Reorg Plus to check more often.  Unless you have DEADLINE set there is no limit to how many times Reorg Plus will check for LONGLOG.  Then at one of these intervals reorg may be able to complete LOGFINAL/SWITCH.

           

          And another possibility is MAXRO:

           

          The default is 300, meaning when Reorg Plus determines (by estimation) that it can complete LOGFINAL in under five minutes it will do the DRAIN and start LOGFINAL and SWITCH.  If this value is increased, along with the DELAY specification being decreased, it is more likely during one of the LONGLOG tests that Reorg Plus will determine it can complete LOGFINAL so it will DRAIN and continue.

           

          I would recommend decreasing DELAY first and see if that works.  If the you still experience LONGLOG conditions and LOGFINAL will not begin, then change the LONGLOG setting to DRAIN to force it to begin LOGFINAL.

           

          Hope this helps

          1 of 1 people found this helpful