1 Reply Latest reply on Dec 7, 2018 8:40 AM by Andreas Mitterdorfer

    Remedy Deployment Manager - ARERR 91

    Catalin Pana

      Hi,

       

      When trying to import a package which has a bigger size (ex: 18.08 Patch 1 for AR Server) the server throws an ARERR91 during import, and consumes ~20GB of RAM from the server (until it reaches 0 MB available, then the error is returned).

       

      The issue appears only for larger packages. For example, ITSM, SLM, SRM, MidTier packages (which are <40MB) are imported without issues. For the MidTier package (30MB) it does give a timeout in the browser, but eventually is able to import it.

       

      I've tried also from CLI, and getting the same error.

       

      Previously BMC stated that the import needs to be run from a server which doesn't have a collection folder (and is not an FTS indexer), and for 18.05 Patch 5 it worked. But now, I'm getting errors from all the servers from which I am trying to import, regardless of their role within the server group.

       

      The plugin in armonitor is set to 4GB of memory available (higher than the recommended 2GB from BMC).

       

      Has anyone else experienced this issue? I suspect it is related to the memory settings in either armonitor or arserverd, but I've had no luck tweaking the settings to make it work.

       

      Thanks

      Catalin

        • 1. Re: Remedy Deployment Manager - ARERR 91
          Andreas Mitterdorfer

          Is there any indication on the problem in arjavaplugin.log or arerror.log?

          Do you have some attachment size setting on ar server or it is set to unlimited?

          Can you try to create a testform with an attachment field (or use an exiting one) and attach one of the larger files to it. Do you experience the same issue?

          Try enabling API/Filter/SQL log to one file on server, when you import such a file and check wheter there are any long running SQL operations.

          1 of 1 people found this helpful