5 Replies Latest reply on Nov 18, 2018 3:46 AM by Abhay Bhagat

    TSPS : Infrastructure Policies stopped getting applied on agent

    Abhay Bhagat

      Dear Experts ,

       

      Infrastructure Policies stopped getting applied on agents

       

      Let me know if someone faced this issue and had a resolution for the same.

       

      Regards

      Abhay

        • 1. Re: TSPS : Infrastructure Policies stopped getting applied on agent
          Razeem Mohamed

          It is possible when the KMs are not pre-loaded. Did you make any changes to the Patrol Agent configuration?

          • 2. Re: TSPS : Infrastructure Policies stopped getting applied on agent
            Michael Evans

            You'll need to give more detail on your environment.

            • TrueSight Version
            • Agent Version
            • KM Version

             

            In general though we've had these types of issues.  There have been a number of reasons (CMA not sending any policies, Agent won't accept policies, others).

            I recommend opening a case with support.  In the mean time...

             

            If NO policies are being pushed to ANY agents then i recommend restarting the entire TSPS environment (the Presentation Server controls agent connections for Infrastructure Policies).

             

            If an agent or two does not accept the policy change then do a 'hard purge'

            1. stop the agent
            2. delete everything in the Patrol_home\Config Directory
            3. start the agent

            we use a script to do this remotely (for windows machines) from Managed Devices

            print(system("mkdir %patrol_home%\\log\\queryagent 2>nul"))

            ;print(system("echo NET STOP PatrolAgent ^>^> %patrol_home%\\log\\queryagent\\PatrolConfig_%date:~10,4%-%date:~4,2%-%date:~7,2%.txt >%patrol_home%\\log\\queryagent\\PatrolPURGE.bat"))

            ;print(system("echo DIR \"%patrol_home%\\config\" ^>^> %patrol_home%\\log\\queryagent\\PatrolConfig_%date:~10,4%-%date:~4,2%-%date:~7,2%.txt >>%patrol_home%\\log\\queryagent\\PatrolPURGE.bat"))

            ;print(system("echo MKDIR \"%patrol_home%\\log\\queryagent\\config-bak\" ^>^> %patrol_home%\\log\\queryagent\\PatrolConfig_%date:~10,4%-%date:~4,2%-%date:~7,2%.txt >>%patrol_home%\\log\\queryagent\\PatrolPURGE.bat"))

            ;print(system("echo COPY \"%patrol_home%\\config\\*.*\" \"%patrol_home%\\log\\queryagent\\config-bak\" ^>^> %patrol_home%\\log\\queryagent\\PatrolConfig_%date:~10,4%-%date:~4,2%-%date:~7,2%.txt >>%patrol_home%\\log\\queryagent\\PatrolPURGE.bat"))

            ;print(system("echo DEL \"%patrol_home%\\config\\*.*\" /Q ^>^> %patrol_home%\\log\\queryagent\\PatrolConfig_%date:~10,4%-%date:~4,2%-%date:~7,2%.txt >>%patrol_home%\\log\\queryagent\\PatrolPURGE.bat"))

            ;print(system("echo NET START PatrolAgent ^>^> %patrol_home%\\log\\queryagent\\PatrolConfig_%date:~10,4%-%date:~4,2%-%date:~7,2%.txt >>%patrol_home%\\log\\queryagent\\PatrolPURGE.bat"))

            ;print(system("echo DIR \"%patrol_home%\\config\" ^>^> %patrol_home%\\log\\queryagent\\PatrolConfig_%date:~10,4%-%date:~4,2%-%date:~7,2%.txt >>%patrol_home%\\log\\queryagent\\PatrolPURGE.bat"))

            ;print(system("echo EXIT >>%patrol_home%\\log\\queryagent\\PatrolPURGE.bat"))

            ;print(system("echo start \"PatrolPurge\" %patrol_home%\\log\\queryagent\\PatrolPURGE.bat >%patrol_home%\\log\\queryagent\\PatrolControl.bat"))

            ;print(system("Start \"PatrolRestart\" %patrol_home%\\log\\queryagent\\PatrolControl.bat"))

            ;

             

             

            Hope that helps

            1 of 1 people found this helpful
            • 3. Re: TSPS : Infrastructure Policies stopped getting applied on agent
              Abhay Bhagat

              Dear Evans ,

               

              Thanks for your response ,

               

              You'll need to give more detail on your environment.

              • TrueSight Version : 11.3.01
              • Agent Version: 11.3
              • KM Version : N/A (All are latest in 11.3 version 2 repository) It is happening for all agents.

               

              I might get an access to environment tommorrow , Will see if the I am able get the TSPS and TSIM restarted and see if it works after the same , If it does not then will get the case opened . 

              • 4. Re: TSPS : Infrastructure Policies stopped getting applied on agent
                Abhay Bhagat

                On 08th Nov I restarted TSPS and TSIM , Since 13.46 on 08th Nov  (after the restart ) I observed that no policies are getting applied on any agent ,  I noticed this on 15th Nov ,

                 

                I will try below

                 

                 

                 

                • Login to tsim server
                • Open Command Prompt in administrator mode
                  • Stop Application (pw sys stop)
                • Go to D:\BMCSoftware\TrueSight\pw\pproxy\PNS\security
                • Double click the pns.reg file to import into the registry.
                • Open Command Prompt in administrator mode
                • Restart Application (pw sys start).
                • Then Login to TSPS server
                • Open Command Prompt in administrator mode
                  • Check the status tssh server status .
                  • Stop Application tssh server stop
                  • Then Start application tssh server start

                 

                Reason : 

                In the log file I could see the error  :-

                ERROR 11/15 13:40:39.755 [ThresholdAndSSAConfigRequest_4] CMA BMC_TS-CMA854038 Exception occurred while initializing PATROL encryption utility

                1. com.bmc.ess.essjni.EssException: Security policy is either missing or unreadable: SOFTWARE\BMC Software\Patrol\SecurityPolicy_v3.0\centralAdmin\common SOFTWARE\BMC Software\Patrol\SecurityPolicy_v3.0\centralAdmin\encryptor 

                at com.bmc.ess.essjni.EssPolicy.<init>(EssPolicy.java:81)

                at com.bmc.unifiedadmin.servercomm.CAPatrolUtils.<init>(CAPatrolUtils.java:43)

                 

                Tentative resolution :-

                https://bmcsites.force.com/casemgmt/sc_KnowledgeArticle?sfdcid=kA214000000d1M9CAI&type=Solution

                 

                Will update on the post if the above steps helps me in getting this resolved .

                 

                Regards

                Abhay

                • 5. Re: TSPS : Infrastructure Policies stopped getting applied on agent
                  Abhay Bhagat

                  Fixed the issue by updating the registry on TSPS server .

                   

                  Regards
                  Abhay