4 Replies Latest reply on Oct 15, 2018 11:39 AM by Guy Guy

    User's cannot login to Self-Service because Language Drop-down never loads

    Aaron Schnabel

      We just upgraded from Track-It! 11 to 2018 and now we have quite a few users who cannot log in to the Self-Service portal because the Language drop-down never loads. It just spins and says "loading". If you click login it says you have to choose a language to login, but you can't choose a language because the drop-down doesn't work.

       

      Ideally I'd like the option to remove having to choose a language at all and just default to English for everyone, but if that isn't possible (which I don't see it in the settings anywhere) we need the drop-down to work.

       

      I've found that for some people, resetting their browser and rebooting will solve the problem temporarily, but it usually comes back the next time they login. Resetting their browser every time they want to put in a ticket is not a sustainable solution.

       

      Does anyone have any ideas on why this is happening and how to solve it?

        • 1. Re: User's cannot login to Self-Service because Language Drop-down never loads
          Cris Coffey

          I haven’t seen that one before Aaron. You may want to call support and open a case to get some assistance with troubleshooting.

          • 2. Re: User's cannot login to Self-Service because Language Drop-down never loads
            Mike Alderman

            We have the same issue!  if you give people the path directly, it works fine.  However, if you hyperlink it from sharepoint, or even a hyperlink in a word doc, it does this.  I did call support but there wasn't a resolution.  I did tag this request onto a few others so I'm sure it simply got lost in the follow up shuffle

            If you go to https://{yourFQDN}/TrackIt/SelfService/Login/ directly does it load?  I simply put this into a block of text on a sharepoint box with directions to copy/paste for now as a workaround.

            • 3. Re: User's cannot login to Self-Service because Language Drop-down never loads
              Aaron Schnabel

              So it turns out for us that the issue only occurs when clicking the link from our internal Joomla site; using the FQDN or not in the link does not make a difference. The language box never loads because it is still trying to authenticate the user and it gets stuck. BMC support is looking in to it and I hope to hear back today.

               

              If we click the link from an email or Word or type the address in directly, the site works fine, it is only an issue when following a link off of our intranet site, so in the meantime I sent out an email and asked users to bookmark the page.

               

              In an effort to try to figure out why this is the only website we've had this kind of issue with I turned on Windows Authentication in IIS and started seeing Invalid Referrer errors in the IIS logs whenever we clicked the link from our intranet page. If you turn off Windows Authentication and go back to Basic Authentication, then you get the language box problem again, but if you open the developer console in IE you see the following errors when trying to login:

               

              SCRIPT70: Permission Denied

              self-service-login.min.js (8,305)

               

              So I'm inclined to believe it's an issue with Track-It! 2018 rather than with our intranet site (especially since the 35+ other webapps, many of which use integrated authentication, work just fine when clicked from there).

               

              If we get a solution from BMC or find one on our own, I will post back. I am glad to hear we're not the only ones who have had this issue though.

              • 4. Re: User's cannot login to Self-Service because Language Drop-down never loads
                Guy Guy

                We have the same issue as well and yes  if you give people the path directly, if anyone finds a solution' please let us know.

                 

                Guy