5 Replies Latest reply on Jul 5, 2018 1:20 AM by Abhishek Singh

    Error while activating module using rest API

    Piyush Mungre

      Hello Orchestrator,

       

      AO Version : 8.0

      HTTP Adapter version : 20.17.01.00

       

      Here is my adapter request :

      <request-data>   
      <http-adapter-request>   
      <http-connection-properties>     
      <Content-Type>application/json</Content-Type>      
      <Authentication-Token>/DwG7gAAAAAAAAAAIXBcZHoNO2I/GyRAMBvzdxEoX3JFDWtcLT4bEMZo95+E3wbHt0XLLfKyNZcm6f4DuCzBEy4I1afxrGaDHXIYCn83p4IYvphze8e4pdq+BlxrHZE39Q64uconQoCzAENsun97rk2RDuN0Ne06WTwpFY+8EmUkOlIEcxXnWtinT7GeAWtrIjJnIDauXN06xcP5m11h+YXKR6ui8h8dj8zksFXNc+iai0QcNKdREUT/iqOVl5LwRsVOOXjWn/m+UA1gPTz1Nk40rqtUc1KChHI2J0pZHf8z91MNhE1ldlwoMN0FB4ICj3VoPWqIG8Gx4RYhEvWXrhoFgbyWZaisBqUT6G+BwNH12MfV3fcNpEtBWhe8Bmat59mrh2R+StnsgJvTMK9Rg8fvx0cC9VSXK0Ho1k5nJuNhgZYZcD/8CyRI+QI48zWjN7dXu0hrHX5yGCxy/shHxyi1Qs=</Authentication-Token>    
      </http-connection-properties>   
      <action>https://CDP_SERVER:28080/baocdp/rest/module/activate</action>    
      <use-ssl-certificate>true</use-ssl-certificate>   
      <install-certificate>true</install-certificate>    
      <allow-unsigned-certificate>true</allow-unsigned-certificate>    
      <passphrase>****MASKED****</passphrase>    
      <ignore-line-break-in-response>true</ignore-line-break-in-response>    
      <file-content-type />    
      <data-format>xml</data-format>    
      <data>{   "modules":[{     "name":"Test_Module",     "version":"01.01.003",     "revision":"1" }] }</data>  
      </http-adapter-request>
      </request-data>


      Adapter Response shows the below error :

       

      <errorMessage>Message[summary=Activation of Test_Module 01.01.003 failed on the following peers: CDP, HACDP. The following peers were successfully rolled back to their previous state: CDP, HACDP. Rollback failed for the following peers: none., detail=Details of failure on peer CDP:

      When activating, deployment was required for Test_Module_01.01.003 and download failed:   Summary:

        Detail: An error occurred while attempting to download the library "Test_Module_01.01.003".

       

      Caused by:

         Summary: Unable to get the library named "/prj/bmc/BAO/CDP/server/grids/GRID1/library/Test_Module.01.01.003_1.roar".

       

        Caused by:

          Summary: An error occurred while attempting to get the resource named "Test_Module.01.01.003.roar" from the repository.

       

         Caused by:

           Summary: No message available. The exception was of type: javax.xml.bind.UnmarshalException

       

          Caused by:

            Summary: Element type "response" must be followed by either attribute specifications, "&gt;" or "/&gt;".

       

      Details of failure on peer HACDP:

      When activating, deployment was required for Test_Module_01.01.003 and download failed:   Summary:

        Detail: An error occurred while attempting to download the library "Test_Module_01.01.003".

       

      Caused by:

         Summary: Unable to get the library named "/prj/bmc/BAO/CDP/server/grids/GRID1/library/Test_Module.01.01.003_1.roar".

       

        Caused by:

          Summary: An error occurred while attempting to get the resource named "Test_Module.01.01.003.roar" from the repository. The server responded with a status code of [500] and a message of "Internal Server Error".

       

      ]</errorMessage>

       

       

      Thanks

       

      Piyush