5 Replies Latest reply on May 18, 2018 2:50 AM by Michael D

    Use old TKUs

    Michael D

      Hi.

       

      Can I use old TKUs from 2016 or 2017 with BMC Discovery 11.3?

       

      Kind regards

        • 1. Re: Use old TKUs
          Andrew Waters

          Do not do that.

           

          You should not use a pre 11.3+ (the first of which is 2018-02-3) on 11.3 because it buildd a different model. For example virtual machines are represented by VirtualMachine node since 11.2. If you discover using a 11.1+ TKU the patterns will build SoftwareInstance rather than VirtualMachine and updating the TKU later would not change the node kind. Similarly 11.3 has changed some HostContainer nodes to HardwareContainer.

           

          Why run anything that old?

          4 of 4 people found this helpful
          • 2. Re: Use old TKUs
            Michael D

            I agree.

             

            I recommend latest version but the customer have a security department that have not autorized the latest TKUs.

             

            Do TPL-files interact with scanned host(s) or do they interact with data in the appliance datastore or maybe both?

             

            Thank you for quick reply:-)

            • 3. Re: Use old TKUs
              Michael D

              If I use old TKU?

               

              Is it impossible technically? Will it "break" the appliance? Or is it just the data in the datastore doesn't have the latest bells and whistles?

               

              Kind regards

              • 4. Re: Use old TKUs
                Andrew Waters

                Pattern modules in TKU ask for commands to be run on devices, examine and update information recorded  on the appliance; so they do both.

                 

                It depends what you mean by break. For example if you ran an old TKU you would not show linked up information between virtual machine and hosts because they do not have the expected node kinds. More problematic is that there is no upgrade path if you apply an old TKU because the changes to the model are performed as part of the upgrade, e.g. converting OsftwareInstances to VirtualMachines when upgrading to 11.2 (or 11.3 if from versions prior to 11.2).

                 

                Really, do not do this. Use an 11.3+ TKU on a 11.3 appliance. They go together.

                4 of 4 people found this helpful
                • 5. Re: Use old TKUs
                  Michael D

                  Thank you for your answers:-)