4 Replies Latest reply on May 17, 2018 3:53 AM by Sidhdesh Punaskar

    Smart IT chat implementation

    Bojan Vladisavljevic

      Hello everyone,

       

      I hope you can help me with the issue I have with Smart IT chat functionality. I upgraded my environment from version 8.1 to version 9.1.04 (ARS, Atrium Core, Atrium Integrator, ITSM, SRM and SLM) on Server1. On Server2 I installed DWP with SmartIT and Openfire that came with the installation, and MongoDB is on separate server Server3.

      As requirement I installed JSS SSO plugin on both Remedy and Smart IT.

       

      I got chat working on both Remedy and Smart IT, but I received requirement to set everything up on secure connection. I created keystore for Remedy Tomcat, generated CSR and received certificate from my CA, installed it and got it working. Additionally I added a rule in web.xml:

       

      <security-constraint>

              <web-resource-collection>

                  <web-resource-name>HTTPSOnly</web-resource-name>

                  <url-pattern>/*</url-pattern>

              </web-resource-collection>

              <user-data-constraint>

                  <transport-guarantee>CONFIDENTIAL</transport-guarantee>

              </user-data-constraint>

          </security-constraint>

       

      to force secure connection to the application. I did the same thing for SmartIT Tomcat. After that I generated self-signed certificate for Openfire and got my CA to sign it:

      These are my settings:

      With all of these settings Chat in Remedy works fine:

      But on SmartIT it wont load anymore:

      These are the settings in connection.properties:

       

      #MyIT server host and port, this is required for Chatter integration

      myit.server.host=Server2

      myit.server.port=443

      NotificationPoller.ENABLED = true

      CommentNotificationService.DELAY = 0

      CommentNotificationService.PERIOD = 180000

      CommentNotificationService.ENABLED = true

      chat.server.cm.host = Server2

      chat.server.client.port = 5223

      chat.server.admin.login = admin

      chat.server.admin.password = a9mVvO%2BOGbI4DNbf6m8JjQ%3D%3D

      chat.server.groupChatService = conference

      chat.server.admin.pool.size = 6

      chat.server.boshUrl = https://Server2:7443/http-bind/

      chat.server.domain = Server2

      api.token.nZXjHqTlhRwvJEGHvGCLHJwVURVzAOibC

       

      I verified bosh URL to be working:

      Openfire error log is almost empty:

       

      ux.log only has INFO and DEBUG entries. There aren't any warnings or errors to analyze. Log ux-error.log is empty:

      I tried capturing Firefox log to try and find the answer, but no luck (I think):

       

      Did anyone perhaps encountered similar situation and has some sort of suggestion where can I look for the solution?

      Please let me know if I could provide additional details or logs?

       

      Regards,

      Bojan

        • 1. Re: Smart IT chat implementation
          Bojan Vladisavljevic

          I may have jumped the gun with ux.log. I found the error:

           

          17:31:55.802 | https-jsse-nio-443-exec-17 | RID: 56 | ERROR   | c.b.b.m.s.c.AuthenticationServiceImpl | Failed validating chat credentials for jid vladisavljevic_000000000000001
          17:31:55.802 | https-jsse-nio-443-exec-17 | RID: 56 | DEBUG   | c.b.b.myit.restapi.LoginResource | Token invalid for JID: vladisavljevic_000000000000001
          17:31:55.803 | https-jsse-nio-443-exec-17 | RID: 56 | DEBUG   | c.b.b.myit.filter.ExpiresFilter | Request '/ux/rest/users/chat/vladisavljevic_000000000000001' with response status '403' content-type 'null', set expiration date Wed May 16 17:31:55 CEST 2018
          17:31:55.803 | https-jsse-nio-443-exec-17 | RID: 56 | DEBUG   | c.b.b.m.s.ApiKeyRequestListener | ApiKeyRequestListener.requestDestroyed: processing request.
          17:31:55.803 | https-jsse-nio-443-exec-17 | RID: 56 | DEBUG   | c.b.b.m.s.ApiKeyRequestListener | ARServerUser objects were not registered - nothing to do

           

          There is an interruption in authentication of my user.

          • 2. Re: Smart IT chat implementation
            Sidhdesh Punaskar

            chat.server.domain = Server2 matches with xmpp.domain from Open fire console setting? Both should be same and with same cases.

            I guess it should be in small cases at both the places.

            KnowledgeArticle - BMC

            • 3. Re: Smart IT chat implementation
              Bojan Vladisavljevic

              Hello Sidhdesh,

               

              Server2 is not the actual name, I had to censor it

              All server names are in lower-case and they match in connect.properties and Server Properties in Openfire configuration form. Configuration worked fine, until I set everything on https. I must have forgotten something, so the authentication string doesn't reach where it should.

              Could there be another reason that server cannot authenticate me?

               

              Regards,

              Bojan